summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/gsl/Config.in10
-rw-r--r--package/gsl/gsl.mk13
3 files changed, 24 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 3f46d3af0..d6a66fd31 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -457,6 +457,7 @@ source "package/libelf/Config.in"
source "package/libevent/Config.in"
source "package/libev/Config.in"
source "package/libffi/Config.in"
+source "package/gsl/Config.in"
source "package/libglib2/Config.in"
source "package/libical/Config.in"
source "package/libnspr/Config.in"
diff --git a/package/gsl/Config.in b/package/gsl/Config.in
new file mode 100644
index 000000000..92541da71
--- /dev/null
+++ b/package/gsl/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GSL
+ bool "gsl"
+ help
+ The GNU Scientific Library (GSL) is a numerical library for
+ C and C++ programmers. The library provides a wide range of
+ mathematical routines such as random number generators,
+ special functions and least-squares fitting. There are over
+ 1000 functions in total with an extensive test suite.
+
+ http://www.gnu.org/software/gsl
diff --git a/package/gsl/gsl.mk b/package/gsl/gsl.mk
new file mode 100644
index 000000000..71968590a
--- /dev/null
+++ b/package/gsl/gsl.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# gnu gsl
+#
+#############################################################
+GSL_VERSION = 1.15
+GSL_SOURCE = gsl-$(GSL_VERSION).tar.gz
+GSL_SITE = $(BR2_GNU_MIRROR)/gsl
+GSL_INSTALL_STAGING = YES
+GSL_LICENSE = GPLv3
+GSL_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))