summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libtpl/Config.in2
-rw-r--r--package/libtpl/libtpl.mk13
2 files changed, 11 insertions, 4 deletions
diff --git a/package/libtpl/Config.in b/package/libtpl/Config.in
index a2c2c2de3..0286e033d 100644
--- a/package/libtpl/Config.in
+++ b/package/libtpl/Config.in
@@ -3,4 +3,4 @@ config BR2_PACKAGE_LIBTPL
help
Easily store and retrieve binary data in C
- http://tpl.sourceforge.net/
+ http://troydhanson.github.io/tpl/
diff --git a/package/libtpl/libtpl.mk b/package/libtpl/libtpl.mk
index 0016c3126..478b2989c 100644
--- a/package/libtpl/libtpl.mk
+++ b/package/libtpl/libtpl.mk
@@ -4,11 +4,18 @@
#
################################################################################
-LIBTPL_VERSION = 1.5
-LIBTPL_SOURCE = libtpl-$(LIBTPL_VERSION).tar.bz2
-LIBTPL_SITE = http://downloads.sourceforge.net/project/tpl/tpl/libtpl-$(LIBTPL_VERSION)
+LIBTPL_VERSION = 445b4e9f236a48e274eaace31acf56d700da142a
+LIBTPL_SITE = http://github.com/troydhanson/tpl/tarball/$(LIBTPL_VERSION)
LIBTPL_INSTALL_STAGING = YES
LIBTPL_LICENSE = BSD-like
LIBTPL_LICENSE_FILES = LICENSE
+LIBTPL_AUTORECONF = YES
+LIBTPL_AUTORECONF_OPT = --install --force
+
+define LIBTPL_CREATE_MISSING_FILES
+ touch $(@D)/NEWS $(@D)/AUTHORS $(@D)/ChangeLog $(@D)/COPYING
+endef
+LIBTPL_POST_EXTRACT_HOOKS += LIBTPL_CREATE_MISSING_FILES
+
$(eval $(autotools-package))