summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--fs/initramfs/Config.in4
-rw-r--r--linux/linux.mk4
2 files changed, 3 insertions, 5 deletions
diff --git a/fs/initramfs/Config.in b/fs/initramfs/Config.in
index 22066eef9..ac4503051 100644
--- a/fs/initramfs/Config.in
+++ b/fs/initramfs/Config.in
@@ -9,8 +9,8 @@ config BR2_TARGET_ROOTFS_INITRAMFS
A rootfs.cpio file will be generated in the images/ directory.
This is the archive that will be included in the kernel image.
- The rootfs in the kernel will always be gzip'ed, regardless
- of how buildroot's cpio archive is configured.
+ The default rootfs compression set in the kernel configuration
+ is used, regardless of how buildroot's cpio archive is configured.
Note that enabling initramfs together with another filesystem
formats doesn't make sense: you would end up having two
diff --git a/linux/linux.mk b/linux/linux.mk
index befef1658..dfc948ca5 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -182,9 +182,7 @@ define LINUX_CONFIGURE_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.cpio\",$(@D)/.config)
$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0,$(@D)/.config)
- $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config)
- $(call KCONFIG_DISABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_NONE,$(@D)/.config)
- $(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config))
+ $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config))
$(if $(BR2_ROOTFS_DEVICE_CREATION_STATIC),,
$(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))