summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/qtopia4/Config.in8
-rw-r--r--package/qtopia4/qtopia4.mk4
-rw-r--r--target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-009-factory.patch33
-rw-r--r--target/u-boot/Makefile.in1
4 files changed, 22 insertions, 24 deletions
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index f29d186a4..fc5a95eb8 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -88,6 +88,13 @@ config BR2_PACKAGE_QTOPIA4_QT3SUPPORT
library with proxy code and increase the space required on target.
If unsure say n.
+config BR2_PACKAGE_QTOPIA4_GUI_MODULE
+ bool "Gui Module"
+ help
+ Turns on support to Gui applications. If your board don't have
+ video output, or you don't require Qt GUI, say n.
+
+if BR2_PACKAGE_QTOPIA4_GUI_MODULE
menu "Pixel depths"
comment "Deselecting each option leads to Qt's default (8,16,32)"
@@ -128,6 +135,7 @@ config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_32
endif
endmenu
+endif
config BR2_PACKAGE_QTOPIA4_GIF
bool "Enable GIF support"
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 569966ed4..9f28ff1c0 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -420,6 +420,10 @@ ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
cp -dpfr $(STAGING_DIR)/usr/plugins/phonon_backend $(TARGET_DIR)/usr/plugins/
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/plugins/phonon_backend/*
endif
+ifneq ($(BR2_PACKAGE_QTOPIA4_GUI_MODULE),y)
+ # Remove Gui library, not needed
+ -rm $(TARGET_DIR)/usr/lib/libQtGui*
+endif
ifneq ($(BR2_PACKAGE_QTOPIA4_SQL_MODULE),y)
# Remove Sql libraries, not needed
-rm $(TARGET_DIR)/usr/lib/libQtSql*
diff --git a/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-009-factory.patch b/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-009-factory.patch
index 7d1c958dc..adbc03bed 100644
--- a/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-009-factory.patch
+++ b/target/device/Atmel/arch-arm/u-boot/2009.01/u-boot-2009.01-009-factory.patch
@@ -109,8 +109,8 @@ diff -urN u-boot-2009.01-0rig//common/cmd_factory.c u-boot-2009.01/common/cmd_fa
+ setenv("fs-date", MK_STR(DATE));
+ setenv("rd", "rootfs.arm-"MK_STR(DATE)".ext2");
+#endif
-+#if defined(KERNEL_VERSION)
-+ setenv("linux", MK_STR(BOARD_NAME)"-linux-"MK_STR(KERNEL_VERSION)"-"MK_STR(DATE)".gz");
++#if defined(KERNEL_NAME)
++ setenv("linux", MK_STR(KERNEL_NAME));
+#endif
+ setenv("get-ramdisk", "tftp ${ramdisk} ${rd}; setenv rd-size ${filesize}");
+ setenv("store-ramdisk", "cp.b ${ramdisk} ${FS} ${rd-size}");
@@ -243,32 +243,17 @@ diff -urN u-boot-2009.01-0rig//common/cmd_factory.c u-boot-2009.01/common/cmd_fa
+
+int do_os (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
+{
-+ char *kchip;
-+ char *kdate;
-+ char *kver;
-+ char cmd[512];
-+ kchip = getenv("hostname");
-+ kdate = getenv("kernel-date");
-+ kver = getenv("kernel-version");
-+ if((strlen(kdate) + strlen(kver) + 32) > 500) {
-+ printf("Error: Environment too large during 'os': ");
-+ printf("len=%d\n", strlen(kdate) + strlen(kver) + 32);
-+ } else if(kver != NULL) {
-+ if(kdate != NULL) {
-+ sprintf(cmd,"%s-linux-%s-%s.gz",kchip,kver,kdate);
-+ } else {
-+ sprintf(cmd,"%s-linux-%s.gz",kchip,kver);
-+ }
-+ printf("Setting kernel to %s\n",cmd);
-+ setenv("linux",cmd);
-+ return 0;
-+ }
-+ return 1;
++#if defined(KERNEL_NAME)
++ setenv("linux", MK_STR(KERNEL_NAME));
++#else
++ setenv("linux", "uImage");
++#endif
++ return 0;
+}
+
+U_BOOT_CMD(
+ os, 1, 1, do_os,
-+ "os\t- Select linux version ${hostname}-linux-${kernel-name}-${kernel-date}\n"
++ "os\t- Select linux version\n"
+ , "\n"
+);
+
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index be889a076..53d9dff0c 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -111,6 +111,7 @@ ifdef BR2_TARGET_UBOOT_DEFAULT_ENV
@echo "#ifndef __BR2_ADDED_CONFIG_H" >> $(U_BOOT_INC_CONF_FILE)
@echo "#define __BR2_ADDED_CONFIG_H" >> $(U_BOOT_INC_CONF_FILE)
$(call insert_define, DATE, $(DATE))
+ $(call insert_define, KERNEL_NAME, $(LINUX26_KERNEL_NAME))
$(call insert_define, CONFIG_LOAD_SCRIPTS, 1)
ifneq ($(strip $(BR2_PROJECT)),"")
$(call insert_define, CONFIG_HOSTNAME, $(BR2_PROJECT))