summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-03-10 08:46:36 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-03-10 08:46:36 +0000
commitf90e0e035b1e8e55b9da4a01fb15017e8dc1b83a (patch)
treee61003dd4d2b866663268b1d936427b42584a072 /toolchain
parent6ff820d647a3b9cfddc284202aa58c6805e02f70 (diff)
downloadbuildroot-novena-f90e0e035b1e8e55b9da4a01fb15017e8dc1b83a.tar.gz
buildroot-novena-f90e0e035b1e8e55b9da4a01fb15017e8dc1b83a.zip
- make sure we use the proper CC for building binutils.
- add config option BR2_EXTRA_BINUTILS_CONFIG_OPTIONS for passing additional flags to binutils configure.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/Config.in9
-rw-r--r--toolchain/binutils/binutils.mk6
2 files changed, 14 insertions, 1 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index 112ff077d..68518f7d5 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -61,3 +61,12 @@ config BR2_BINUTILS_VERSION
default "2.16.91.0.4" if BR2_BINUTILS_VERSION_2_16_91_0_4
default "2.16.91.0.5" if BR2_BINUTILS_VERSION_2_16_91_0_5
default "2.16.91.0.6" if BR2_BINUTILS_VERSION_2_16_91_0_6
+
+
+config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
+ string "Additional binutils options"
+ default ""
+ help
+ Any additional binutils options you may want to include..
+
+
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index e6174d422..c5cdae0e9 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -5,6 +5,8 @@
#############################################################
BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
+EXTRA_BINUTILS_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_BINUTILS_CONFIG_OPTIONS)))
+#"
BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
ifeq ($(BINUTILS_VERSION),2.16)
BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/
@@ -49,6 +51,7 @@ $(BINUTILS_DIR)/.patched: $(BINUTILS_DIR)/.unpacked
$(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
mkdir -p $(BINUTILS_DIR1)
(cd $(BINUTILS_DIR1); \
+ CC="$(HOSTCC)" \
$(BINUTILS_DIR)/configure \
--prefix=$(STAGING_DIR) \
--build=$(GNU_HOST_NAME) \
@@ -57,7 +60,8 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
$(DISABLE_NLS) \
$(MULTILIB) \
--disable-werror \
- $(SOFT_FLOAT_CONFIG_OPTION) );
+ $(SOFT_FLOAT_CONFIG_OPTION) \
+ $(EXTRA_BINUTILS_CONFIG_OPTIONS));
touch $(BINUTILS_DIR1)/.configured
$(BINUTILS_DIR1)/binutils/objdump: $(BINUTILS_DIR1)/.configured