summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-09-29 20:44:30 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-09-29 20:44:30 +0000
commitf885e239ea23956176fb92d9a5a737da324b04eb (patch)
tree7d3323485147faf67d7f7fc310931bfefe41e56a /toolchain
parente6382c49a46a36e2e1241d9a33a9f5f246a57e19 (diff)
downloadbuildroot-novena-f885e239ea23956176fb92d9a5a737da324b04eb.tar.gz
buildroot-novena-f885e239ea23956176fb92d9a5a737da324b04eb.zip
Revert modification of gcc, and make it AVR32 specific
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile.in6
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
2 files changed, 7 insertions, 3 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 01a0e9560..e12f29daa 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -14,6 +14,9 @@ EXTRA_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_GCC_CONFIG_OPTIONS)))
# AVR32 GCC configuration
ifeq ($(strip $(BR2_avr32)),y)
EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
+EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--disable-libssp
+EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
+#EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--with-as=$(TARGET_CROSS)as
endif
ifeq ($(strip $(subst ",, $(BR2_GCC_IS_SNAP))),y)
@@ -79,6 +82,9 @@ EXTRA_TARGET_GCC_CONFIG_OPTIONS:=
# AVR32 target GCC configuration
ifeq ($(strip $(BR2_avr32)),y)
EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--disable-libmudflap
+EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--disable-libssp
+EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
+#EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--with-as=$(TARGET_CROSS)as
endif
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 733dbe6ba..db7c9064c 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -187,7 +187,6 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \
- --with-as=$(TARGET_CROSS)as \
--disable-shared \
$(GCC_WITH_HOST_GMP) \
$(GCC_WITH_HOST_MPFR) \
@@ -252,8 +251,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(GCC_STAGING_PREREQ)
--enable-languages=$(GCC_CROSS_LANGUAGES) \
--disable-__cxa_atexit \
--enable-target-optspace \
- --with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
- --disable-libssp \
+ --with-gnu-ld \
$(GCC_WITH_HOST_GMP) \
$(GCC_WITH_HOST_MPFR) \
$(GCC_SHARED_LIBGCC) \