summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-13 19:55:27 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-13 19:55:27 +0000
commitee1285f23fe5a043c6fdc40067117ddff0915042 (patch)
tree2f1fb4c1b74fc34f6ad913eeb372826744e68d38 /toolchain
parent3f684225a329ea2ab72e9cc66079278647e9df09 (diff)
downloadbuildroot-novena-ee1285f23fe5a043c6fdc40067117ddff0915042.tar.gz
buildroot-novena-ee1285f23fe5a043c6fdc40067117ddff0915042.zip
- Build binutils with sysroot support.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/binutils.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index 98e08597d..590935fa8 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -62,6 +62,8 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
--build=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
+ --with-build-sysroot="$(TOOL_BUILD_DIR)/uClibc_dev/" \
+ --with-sysroot="$(TOOL_BUILD_DIR)/uClibc_dev/" \
$(DISABLE_NLS) \
$(MULTILIB) \
--disable-werror \
@@ -77,7 +79,7 @@ $(BINUTILS_DIR1)/binutils/objdump: $(BINUTILS_DIR1)/.configured
$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld: $(BINUTILS_DIR1)/binutils/objdump
$(MAKE) -C $(BINUTILS_DIR1) install
-binutils: dependencies $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld
+binutils: dependencies uclibc-configured $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld
binutils-source: $(DL_DIR)/$(BINUTILS_SOURCE)