summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-24 11:30:05 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-24 11:30:05 +0000
commita6dbba6c24b2965da274e8f840096aecfa14a409 (patch)
treeef7fcd3f56019c768a8c995a166569d22925397d /toolchain
parent17bc94ad53ba453326c7f2bb163635372fd34992 (diff)
downloadbuildroot-novena-a6dbba6c24b2965da274e8f840096aecfa14a409.tar.gz
buildroot-novena-a6dbba6c24b2965da274e8f840096aecfa14a409.zip
- disable sysroot support for anything but the current, stable release series
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in9
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk5
3 files changed, 11 insertions, 7 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 3dc5352ca..fa60e38db 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -52,7 +52,7 @@ choice
bool "gcc 4.0.3"
config BR2_GCC_VERSION_4_0_4
- depends !BR2_nios2
+ depends !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.0.4"
config BR2_GCC_VERSION_4_1_0
@@ -84,7 +84,7 @@ config BR2_GCC_IS_SNAP
config BR2_GCC_SNAP_DATE
string "GCC snapshot date"
- default "20070601"
+ default "20070622"
depends BR2_GCC_IS_SNAP
help
Enter snapshot date to use for gcc. Format is:
@@ -113,7 +113,7 @@ config BR2_GCC_VERSION
config BR2_TOOLCHAIN_SYSROOT
# bool "Enable toolchain with --sysroot support"
bool
- depends on !BR2_GCC_VERSION_3_3_5 && !BR2_GCC_VERSION_3_3_6 && !BR2_GCC_VERSION_3_4_2 && !BR2_GCC_VERSION_3_4_3 && !BR2_GCC_VERSION_3_4_4 && !BR2_GCC_VERSION_3_4_5 && !BR2_GCC_VERSION_3_4_6
+ depends on !BR2_GCC_VERSION_3_3_5 && !BR2_GCC_VERSION_3_3_6 && !BR2_GCC_VERSION_3_4_2 && !BR2_GCC_VERSION_3_4_3 && !BR2_GCC_VERSION_3_4_4 && !BR2_GCC_VERSION_3_4_5 && !BR2_GCC_VERSION_3_4_6 &&!BR2_GCC_VERSION_4_0_0 && !BR2_GCC_VERSION_4_0_1 && !BR2_GCC_VERSION_4_0_2 && !BR2_GCC_VERSION_4_0_3 && !BR2_GCC_VERSION_4_0_4 && !BR2_GCC_VERSION_4_1_0 && !BR2_GCC_VERSION_4_1_1 && !BR2_GCC_VERSION_4_1_2
default y
help
Enables --sysroot=dir for binutils and gcc.
@@ -122,6 +122,9 @@ config BR2_TOOLCHAIN_SYSROOT
/usr/include and libraries in /usr/lib, it will instead search
dir/usr/include and dir/usr/lib.
+ This does not work with gcc < 4.2.0 (4.1.2 gets
+ ORIGINAL_AS_FOR_TARGET wrong)
+
config BR2_GCC_USE_SJLJ_EXCEPTIONS
bool "Enable setjmp/longjmp exceptions?"
default n
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 8d8e6f21e..2e81c96ca 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -19,8 +19,8 @@
ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
-# only for gcc-3.x
-ifeq ($(findstring y,$(BR2_GCC_VERSION_3_3_5)$(BR2_GCC_VERSION_3_3_6)$(BR2_GCC_VERSION_3_4_2)$(BR2_GCC_VERSION_3_4_3)$(BR2_GCC_VERSION_3_4_4)$(BR2_GCC_VERSION_3_4_5)$(BR2_GCC_VERSION_3_4_6)),y)
+# without sysroot support. Sysroot toolchain is gcc-uclibc-4.x.mk
+ifneq ($(BR2_TOOLCHAIN_SYSROOT),y)
ifeq ($(GCC_SNAP_DATE),)
GCC_OFFICIAL_VER:=$(GCC_VERSION)
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 2d69bdd94..89f7a45e9 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -17,8 +17,9 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-# gcc-4.x only
-ifeq ($(findstring y,$(BR2_GCC_VERSION_3_3_5)$(BR2_GCC_VERSION_3_3_6)$(BR2_GCC_VERSION_3_4_2)$(BR2_GCC_VERSION_3_4_3)$(BR2_GCC_VERSION_3_4_4)$(BR2_GCC_VERSION_3_4_5)$(BR2_GCC_VERSION_3_4_6)),)
+# sysroot support works with gcc >= 4.2.0 only
+ifeq ($(BR2_TOOLCHAIN_SYSROOT),y)
+
ifeq ($(GCC_SNAP_DATE),)
GCC_OFFICIAL_VER:=$(GCC_VERSION)
GCC_SITE:=http://ftp.gnu.org/gnu/gcc/gcc-$(GCC_VERSION)