summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-07 12:28:25 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-07 12:28:25 +0000
commit4bb783dbe46fa9d92ad5baf892892b6c2c418b99 (patch)
treefc03126fba887437a7ab5dde697a0d00a3de0cd3 /toolchain
parent1904280ac9247dcc280574eccf452f9bc5657be3 (diff)
downloadbuildroot-novena-4bb783dbe46fa9d92ad5baf892892b6c2c418b99.tar.gz
buildroot-novena-4bb783dbe46fa9d92ad5baf892892b6c2c418b99.zip
Avoid stripping scripts
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index dd3ad0978..68f1f7ca6 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -247,17 +247,13 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
mv "$(STAGING_DIR)/lib64/"* "$(STAGING_DIR)/lib/" ; \
rmdir "$(STAGING_DIR)/lib64" ; \
fi
+ # Move gcc bug reporting script out of path of real executables
+ mv -f $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gccbug \
+ $(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-gccbug
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- if [ -e $(STAGING_DIR)/usr/bin/*-gccbug ] ; then \
- mkdir -p "$(STAGING_DIR)/tmp" ; \
- mv $(STAGING_DIR)/usr/bin/*-gccbug $(STAGING_DIR)/tmp ; \
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/* ; \
- mv $(STAGING_DIR)/tmp/*-gccbug $(STAGING_DIR)/usr/bin ; \
- rmdir "$(STAGING_DIR)/tmp" ; \
- else \
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/* ; \
- fi
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/faked
endif
# Make sure we have 'cc'.
if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ] ; then \