summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-05 05:15:47 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-05 05:15:47 +0000
commit3b2d67133581038c4168a9b32f068da259b9b450 (patch)
tree13be33a69b91f2b5a690509a2b6f5eb60d84819a /toolchain
parentac211bea29c42bb39de8fdec13134fa11519e404 (diff)
downloadbuildroot-novena-3b2d67133581038c4168a9b32f068da259b9b450.tar.gz
buildroot-novena-3b2d67133581038c4168a9b32f068da259b9b450.zip
This was for when I was building a toolchain without BR2_TOOLCHAIN_SYSROOT set. Maybe when it is set the C++ libraries get put into $(TARGET_DIR)/lib. If that is the case, then an 'if-else' block will need to be placed to strip the right location.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 2e81c96ca..5f148d278 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -306,7 +306,7 @@ ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
-cp -dpf $(STAGING_DIR)/lib/libstdc++.so* $(TARGET_DIR)/usr/lib/
- $(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libstdc++.so*
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/usr/lib/libstdc++.so*
endif
ifeq ($(BR2_INSTALL_LIBGCJ),y)
-cp -dpf $(STAGING_DIR)/lib/libgcj.so* $(TARGET_DIR)/usr/lib/