summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-30 12:42:59 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-30 12:42:59 +0000
commit28b852d9c3b69761626ac63adef28e414ef1d1df (patch)
tree22f00761bdcc588ddfee2a48657b4bfd892691fa /toolchain
parentca340986fee3af61ff45665f22eed351ccfb9c91 (diff)
downloadbuildroot-novena-28b852d9c3b69761626ac63adef28e414ef1d1df.tar.gz
buildroot-novena-28b852d9c3b69761626ac63adef28e414ef1d1df.zip
- propagate mips ISA down to uClibc
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/uclibc.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 1bef774f0..9ce47289a 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -150,9 +150,16 @@ endif
endif
ifeq ($(UCLIBC_TARGET_ARCH),mips)
$(SED) '/CONFIG_MIPS_[NO].._ABI/d' $(UCLIBC_DIR)/.oldconfig
+ $(SED) '/CONFIG_MIPS_ISA_.*/d' $(UCLIBC_DIR)/.oldconfig
(/bin/echo "# CONFIG_MIPS_O32_ABI is not set"; \
/bin/echo "# CONFIG_MIPS_N32_ABI is not set"; \
/bin/echo "# CONFIG_MIPS_N64_ABI is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_1 is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_2 is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_3 is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_4 is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_MIPS32 is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_MIPS64 is not set"; \
) >> $(UCLIBC_DIR)/.oldconfig
ifeq ($(BR2_MIPS_OABI),y)
$(SED) 's/.*\(CONFIG_MIPS_O32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
@@ -163,6 +170,27 @@ endif
ifeq ($(BR2_MIPS_ABI64),y)
$(SED) 's/.*\(CONFIG_MIPS_N64_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
+ifeq ($(BR2_mips_1),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_1\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_2),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_2\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_3),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_3\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_4),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_4\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_32),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_32r2),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_64),y)
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS64\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
endif
ifeq ($(UCLIBC_TARGET_ARCH),sh)
/bin/echo "# CONFIG_SH2A is not set" >> $(UCLIBC_DIR)/.oldconfig