summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-09 13:05:43 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-09 13:05:43 +0000
commit19818694fe6fa3412a6636a3ed783e0d6832d6e6 (patch)
tree13e3648e89e2270157444cb081badf5dbd8bcbf6 /toolchain
parent078013d8aea5f30ee5ad9435561231d972ef2c88 (diff)
downloadbuildroot-novena-19818694fe6fa3412a6636a3ed783e0d6832d6e6.tar.gz
buildroot-novena-19818694fe6fa3412a6636a3ed783e0d6832d6e6.zip
- fix crosscompiler prerequisites
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/binutils.mk9
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk2
2 files changed, 9 insertions, 2 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index e75e4c9db..73e70180d 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -40,8 +40,15 @@ endif
# We do not rely on the host's gmp/mpfr but use a known working one
BINUTILS_HOST_PREREQ:=
BINUTILS_TARGET_PREREQ:=
-ifndef BINUTILS_NO_MPFR
+ifeq ($(findstring 3.,$(GCC_VERSION)),3.)
+BINUTILS_NO_MPFR:=y
+endif
+ifeq ($(findstring 4.0,$(GCC_VERSION)),4.0)
+BINUTILS_NO_MPFR:=y
+endif
+
+ifndef BINUTILS_NO_MPFR
BINUTILS_HOST_PREREQ:=$(TOOL_BUILD_DIR)/gmp/lib/libgmp.so \
$(TOOL_BUILD_DIR)/mpfr/lib/libmpfr.so
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 45e4181f0..17832148f 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -72,7 +72,7 @@ endif
GCC_TARGET_PREREQ =
GCC_STAGING_PREREQ= $(STAGING_DIR)/lib/libc.a
-ifndef $(GCC_NO_MPFR)
+ifndef GCC_NO_MPFR
GCC_WITH_HOST_GMP=--with-gmp=$(GMP_HOST_DIR)
GCC_WITH_HOST_MPFR=--with-mpfr=$(MPFR_HOST_DIR)