summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/uclibc.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-04-04 07:29:45 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-11 09:22:48 +0200
commit9474421da36d8602f56b84b150e4cf4c78e788b3 (patch)
tree80ff1369f505ad06137f14e8e37cf8b02adda541 /toolchain/uClibc/uclibc.mk
parent36319e23e84fd04dec18d5cdce9848fff25f2cb0 (diff)
downloadbuildroot-novena-9474421da36d8602f56b84b150e4cf4c78e788b3.tar.gz
buildroot-novena-9474421da36d8602f56b84b150e4cf4c78e788b3.zip
toolchain/arm: drop generic and old, add fa526/626, unify strongarm
* Add Faraday FA526/626 as suggested on bug #1291 Note however that these cores are v4 and NOT v4t. * Make the sa110 & sa1110 cores -> strongarm since they're the same. * Drop all of the ARM variants lower than v4 including generic, there's no point in supporting obsolete targets. * Fix uClibc USE_BX logic, it was always on, this would break the new FA526/626 support and broke StrongARM since it's a v4 core. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/uClibc/uclibc.mk')
-rw-r--r--toolchain/uClibc/uclibc.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index e8b2bb494..113dc79e5 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -130,6 +130,9 @@ ifeq ($(BR2_ARM_OABI),y)
/bin/echo "CONFIG_ARM_OABI=y" >> $(UCLIBC_DIR)/.oldconfig
/bin/echo "# CONFIG_ARM_EABI is not set" >> $(UCLIBC_DIR)/.oldconfig
endif
+ifeq ($(BR2_fa526)$(BR2_strongarm),y)
+ $(SED) 's,USE_BX=y,# USE_BX is not set,' $(UCLIBC_DIR)/.oldconfig
+endif
endif
ifeq ($(UCLIBC_TARGET_ARCH),mips)
$(SED) '/CONFIG_MIPS_[NO].._ABI/d' $(UCLIBC_DIR)/.oldconfig