summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-26 21:12:38 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-26 21:12:38 +0000
commit4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb (patch)
tree56762054e7ac277378262dd98c4ff8c9c55a7d1e /toolchain/gcc
parent02f18650097aed6c71f704c38c4dc55039286248 (diff)
downloadbuildroot-novena-4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb.tar.gz
buildroot-novena-4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb.zip
- revert some bad checkins, fixup bad settings in atmel targets and move the gcc target abi back to a place where the other arch-specific settings live
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in34
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk13
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk11
3 files changed, 10 insertions, 48 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 07cea045c..93c7a4de5 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -69,40 +69,6 @@ config BR2_GCC_VERSION
default "4.2.1" if BR2_GCC_VERSION_4_2_1
default "4.3" if BR2_GCC_VERSION_4_3
-choice
- prompt "Target ABI"
- depends BR2_arm || BR2_armeb
- default BR2_ARM_OABI
- help
- Application Binary Interface to use
-
-config BR2_ARM_OABI
- bool "OABI"
-config BR2_ARM_EABI
- bool "EABI"
-endchoice
-
-config BR2_GCC_TARGET_ABI
- string
- default apcs-gnu if BR2_arm_dunno
- default atpcs if BR2_arm_dunno
- default aapcs if BR2_arm_dunno
- default aapcs-linux if BR2_arm_dunno
- default iwmmxt if BR2_iwmmxt
- default 32 if BR2_mipsel && BR2_OABI
- default n32 if BR2_mipsel && BR2_EABI
- default o64 if BR2_mips && BR2_OABI
- default 64 if BR2_mips && BR2_ABI64
- default eabi if BR2_mips && BR2_EABI
- default mmixware if BR2_mmix && BR2_ABI_native
- default gnu if BR2_mmix && !BR2_ABI_native
- default altivec if BR2_powerpc && BR2_ABI_altivec
- default no-altivec if BR2_powerpc && BR2_ABI_no-altivec
- default spe if BR2_powerpc && BR2_ABI_spe
- default no-spe if BR2_powerpc && BR2_ABI_no-spe
- default ibmlongdouble if BR2_powerpc && BR2_ABI_ibmlongdouble
- default ieeelongdouble if BR2_powerpc && BR2_ABI_ieeelongdouble
-
config BR2_TOOLCHAIN_SYSROOT
bool "Enable toolchain with --sysroot support"
depends on BR2_GCC_SUPPORTS_SYSROOT
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index bb34797be..cc56cafe3 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -17,7 +17,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
# without sysroot support. Sysroot toolchain is gcc-uclibc-4.x.mk
ifneq ($(BR2_TOOLCHAIN_SYSROOT),y)
@@ -33,15 +33,16 @@ endif
# redefine if using an external prepatched gcc source
-ifeq ($(BR2_TOOLCHAIN_NORMAL),)
+ifneq ($(BR2_TOOLCHAIN_BUILDROOT),y)
GCC_SITE:=$(VENDOR_SITE)
GCC_OFFICIAL_VER:=$(GCC_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GCC_RELEASE)
+GCC_PATCH_DIR:=$(VENDOR_PATCH_DIR)/gcc-$(GCC_OFFICIAL_VER)
endif
GCC_SOURCE:=gcc-$(GCC_OFFICIAL_VER).tar.bz2
GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_OFFICIAL_VER)
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
ifeq ($(GCC_SNAP_DATE),)
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
else
@@ -51,16 +52,12 @@ else
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
endif
endif
-else
-GCC_PATCH_DIR:=$(VENDOR_PATCH_DIR)/gcc-$(GCC_OFFICIAL_VER)
endif
-
GCC_CAT:=$(BZCAT)
GCC_STRIP_HOST_BINARIES:=true
-
-ifeq ($(findstring 3.,$(GCC_VERSION)),3.)
+ifeq ($(findstring x3.,x$(GCC_VERSION)),x3.)
GCC_NO_MPFR:=y
else
ifneq ($(BR2_INSTALL_FORTRAN),y)
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 7b6ceb032..59b9a7e07 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -30,13 +30,14 @@ GCC_SITE:=ftp://sources.redhat.com/pub/gcc/snapshots/$(GCC_OFFICIAL_VER)
endif
# redefine if using an external prepatched gcc source
-ifeq ($(BR2_TOOLCHAIN_NORMAL),)
+ifneq ($(BR2_TOOLCHAIN_BUILDROOT),y)
GCC_SITE:=$(VENDOR_SITE)
GCC_OFFICIAL_VER:=$(GCC_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GCC_RELEASE)
-endif
+GCC_PATCH_DIR:=$(VENDOR_PATCH_DIR)/gcc-$(GCC_OFFICIAL_VER)
+endif #!BR2_TOOLCHAIN_BUILDROOT
# define patch location
-ifeq ($(BR2_TOOLCHAIN_NORMAL),y) # Normal toolchain
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y) # Normal toolchain
ifeq ($(GCC_SNAP_DATE),) # Not a snapshot
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
else # Is a snapshot
@@ -47,9 +48,7 @@ else # Normal patch to snapshot
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
endif # Snapshot patch
endif # Not a snapshot
-else # Prepatched toolchain
-GCC_PATCH_DIR:=$(VENDOR_PATCH_DIR)/gcc-$(GCC_OFFICIAL_VER)
-endif # Normal toolchain
+endif # BR2_TOOLCHAIN_BUILDROOT
GCC_SOURCE:=gcc-$(GCC_OFFICIAL_VER).tar.bz2
GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_OFFICIAL_VER)