summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-23 22:26:29 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 12:46:08 +0100
commitb8103112ea8d9d03647a60f45768494dc14eaa1b (patch)
treeea94d21488ad9f34cd9d00c2008181ea0b869472 /toolchain/gcc/gcc-uclibc-4.x.mk
parente30c5bc58e35b1043f0fe619b6aca122558344d0 (diff)
downloadbuildroot-novena-b8103112ea8d9d03647a60f45768494dc14eaa1b.tar.gz
buildroot-novena-b8103112ea8d9d03647a60f45768494dc14eaa1b.zip
gcc: add support for gcc 4.8
This commit adds support for the recently released gcc 4.8. We re-add the same patch series as the one used for 4.7.x, after refreshing the patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 3bfa13ba5..4f1bb4984 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -191,6 +191,16 @@ endif
GCC_HOST_PREREQ += host-mpc
endif
+# GCC 4.8.x prerequisites
+ifeq ($(findstring x4.8.,x$(GCC_VERSION)),x4.8.)
+GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+GCC_TARGET_PREREQ += mpc
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+HOST_SOURCE += host-mpc-source
+endif
+GCC_HOST_PREREQ += host-mpc
+endif
+
# GCC snapshot prerequisites
# Since we don't know and it can be quite new just ask for everything known
ifneq ($(GCC_SNAP_DATE),)