summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/gcc-uclibc-3.x.mk
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-09-03 06:10:01 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-09-03 06:10:01 +0000
commit82d52e8d84ab2d54bcc23cb6893517055c1ad5c3 (patch)
treefe33fed0a74643b18d282f57ffbb6df69c4a7eb9 /toolchain/gcc/gcc-uclibc-3.x.mk
parenta3c9cecb2ae165ddcb6420354d9d6284eef8da90 (diff)
downloadbuildroot-novena-82d52e8d84ab2d54bcc23cb6893517055c1ad5c3.tar.gz
buildroot-novena-82d52e8d84ab2d54bcc23cb6893517055c1ad5c3.zip
Cleanup handling of gccbug script
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-3.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 1dff9ebed..a21e9a0ad 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -282,7 +282,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
fi
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/*
+ strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
endif
# Make sure we have 'cc'.
if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \