summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile.in
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2005-04-30 22:59:05 +0000
committerManuel Novoa III <mjn3@codepoet.org>2005-04-30 22:59:05 +0000
commit51b8148162a9b02837a83202b740612e702494d4 (patch)
tree5133ac8d37bb821c4570c730508d88060fc3b682 /toolchain/gcc/Makefile.in
parent7b67264adf9f1c86369471fbaeee4a8e87c127c7 (diff)
downloadbuildroot-novena-51b8148162a9b02837a83202b740612e702494d4.tar.gz
buildroot-novena-51b8148162a9b02837a83202b740612e702494d4.zip
Fix soft float options for gcc 4.
Diffstat (limited to 'toolchain/gcc/Makefile.in')
-rw-r--r--toolchain/gcc/Makefile.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index c89eb4227..908a45276 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -21,6 +21,13 @@ SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
else
SOFT_FLOAT_CONFIG_OPTION:=--without-float
endif
+# again... there must be a better way
+ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+endif
+ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+endif
TARGET_SOFT_FLOAT:=-msoft-float
ARCH_FPU_SUFFIX:=_nofpu
else