summaryrefslogtreecommitdiffstats
path: root/toolchain/dependancies/dependancies.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-05-02 21:35:55 +0000
committerEric Andersen <andersen@codepoet.org>2006-05-02 21:35:55 +0000
commit00e245b59fa27df0d83c3c1916180c8f97b33726 (patch)
treeedd6ba0702d728967387f55e8fd3180be4e55562 /toolchain/dependancies/dependancies.mk
parent6b2f95f295e5ac93b6b045c09a3df757d01fc2c6 (diff)
downloadbuildroot-novena-00e245b59fa27df0d83c3c1916180c8f97b33726.tar.gz
buildroot-novena-00e245b59fa27df0d83c3c1916180c8f97b33726.zip
Add some finer grained dependancy checking. Check that
make >= 3.80 is installed, check that at least gcc 2.95 is installed. Other dependancy will be added as needed.
Diffstat (limited to 'toolchain/dependancies/dependancies.mk')
-rw-r--r--toolchain/dependancies/dependancies.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/toolchain/dependancies/dependancies.mk b/toolchain/dependancies/dependancies.mk
new file mode 100644
index 000000000..a0da2509f
--- /dev/null
+++ b/toolchain/dependancies/dependancies.mk
@@ -0,0 +1,25 @@
+######################################################################
+#
+# Check buildroot dependancies and bail out if the user's
+# system is judged to be lacking....
+#
+######################################################################
+
+dependancies:
+ $(TOPDIR)/toolchain/dependancies/dependancies.sh
+
+dependancies-source:
+
+dependancies-clean:
+ rm -f $(SSTRIP_TARGET)
+
+dependancies-dirclean:
+ true
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+# unconditionally include this one...
+TARGETS+=dependancies