summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2005-04-30 21:51:23 +0000
committerManuel Novoa III <mjn3@codepoet.org>2005-04-30 21:51:23 +0000
commit42b8eb1908735ca4c0fd2709b5ba6a74a45e5d61 (patch)
treec6ee1a5e9c418f575f3c10b897d13fc5ea778326 /toolchain/binutils
parentc996726e3869cf4ad6901dee4171fd388c7c601b (diff)
downloadbuildroot-novena-42b8eb1908735ca4c0fd2709b5ba6a74a45e5d61.tar.gz
buildroot-novena-42b8eb1908735ca4c0fd2709b5ba6a74a45e5d61.zip
Needed --disable-werror to get 2.16.mumble build from dying on missing prototypes in lex-generated files.
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/binutils.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index ef9c3dc0a..22f66331b 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -6,6 +6,9 @@
BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
+ifeq ($(BINUTILS_VERSION),2.16)
+BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/
+endif
ifeq ($(BINUTILS_VERSION),2.15)
BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/
endif
@@ -46,6 +49,7 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
--target=$(REAL_GNU_TARGET_NAME) \
$(DISABLE_NLS) \
$(MULTILIB) \
+ --disable-werror \
$(SOFT_FLOAT_CONFIG_OPTION) );
touch $(BINUTILS_DIR1)/.configured
@@ -104,6 +108,7 @@ $(BINUTILS_DIR2)/.configured: $(BINUTILS_DIR)/.patched
--target=$(REAL_GNU_TARGET_NAME) \
$(DISABLE_NLS) \
$(MULTILIB) \
+ --disable-werror \
$(SOFT_FLOAT_CONFIG_OPTION) );
touch $(BINUTILS_DIR2)/.configured