summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/binutils.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-05-02 21:35:55 +0000
committerEric Andersen <andersen@codepoet.org>2006-05-02 21:35:55 +0000
commit00e245b59fa27df0d83c3c1916180c8f97b33726 (patch)
treeedd6ba0702d728967387f55e8fd3180be4e55562 /toolchain/binutils/binutils.mk
parent6b2f95f295e5ac93b6b045c09a3df757d01fc2c6 (diff)
downloadbuildroot-novena-00e245b59fa27df0d83c3c1916180c8f97b33726.tar.gz
buildroot-novena-00e245b59fa27df0d83c3c1916180c8f97b33726.zip
Add some finer grained dependancy checking. Check that
make >= 3.80 is installed, check that at least gcc 2.95 is installed. Other dependancy will be added as needed.
Diffstat (limited to 'toolchain/binutils/binutils.mk')
-rw-r--r--toolchain/binutils/binutils.mk20
1 files changed, 1 insertions, 19 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index 7658ce0b3..89820fced 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -73,25 +73,7 @@ $(BINUTILS_DIR1)/binutils/objdump: $(BINUTILS_DIR1)/.configured
$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld: $(BINUTILS_DIR1)/binutils/objdump
$(MAKE) -C $(BINUTILS_DIR1) install
-binutils-dependancies:
- @if ! which which > /dev/null ; then \
- echo -e "\n\nYou must install 'which' on your build machine\n"; \
- exit 1; \
- fi;
- @if ! which bison > /dev/null ; then \
- echo -e "\n\nYou must install 'bison' on your build machine\n"; \
- exit 1; \
- fi;
- @if ! which flex > /dev/null ; then \
- echo -e "\n\nYou must install 'flex' on your build machine\n"; \
- exit 1; \
- fi;
- @if ! which msgfmt > /dev/null ; then \
- echo -e "\n\nYou must install 'gettext' on your build machine\n"; \
- exit 1; \
- fi;
-
-binutils: binutils-dependancies $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld
+binutils: dependancies $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld
binutils-source: $(DL_DIR)/$(BINUTILS_SOURCE)