summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-03-09 17:30:20 +0000
committerEric Andersen <andersen@codepoet.org>2005-03-09 17:30:20 +0000
commitd93b209d352be71cdf966bf86fe3659d8fabeb38 (patch)
tree4c6352c5b2a14e1efe434457e07091ce0ef819e0 /target
parent318cae634df9379c90cf5dd2b68a63766cfc3474 (diff)
downloadbuildroot-novena-d93b209d352be71cdf966bf86fe3659d8fabeb38.tar.gz
buildroot-novena-d93b209d352be71cdf966bf86fe3659d8fabeb38.zip
Fixup device table location
Diffstat (limited to 'target')
-rw-r--r--target/jffs2/Config.in25
-rw-r--r--target/jffs2/jffs2root.mk7
2 files changed, 14 insertions, 18 deletions
diff --git a/target/jffs2/Config.in b/target/jffs2/Config.in
index 6836e04f7..ff3156b7b 100644
--- a/target/jffs2/Config.in
+++ b/target/jffs2/Config.in
@@ -8,52 +8,47 @@ config BR2_TARGET_ROOTFS_JFFS2_EBSIZE
hex "Erase block size"
depends on BR2_TARGET_ROOTFS_JFFS2
default 0x20000
-
+
config BR2_TARGET_ROOTFS_JFFS2_PAD
bool "Pad output"
depends on BR2_TARGET_ROOTFS_JFFS2
-
+
config BR2_TARGET_ROOTFS_JFFS2_PADSIZE
hex "Pad output size (0x0 = to end of EB)"
depends on BR2_TARGET_ROOTFS_JFFS2_PAD
default 0x0
help
- Set to 0x0 to pad to end of erase block.
-
+ Set to 0x0 to pad to end of erase block.
+
choice
prompt "Endianess"
default BR2_TARGET_ROOTFS_JFFS2_LE
depends on BR2_TARGET_ROOTFS_JFFS2
-
+
config BR2_TARGET_ROOTFS_JFFS2_LE
bool "little-endian"
depends on BR2_TARGET_ROOTFS_JFFS2
-
+
config BR2_TARGET_ROOTFS_JFFS2_BE
bool "big-endian"
depends on BR2_TARGET_ROOTFS_JFFS2
-
+
endchoice
config BR2_TARGET_ROOTFS_JFFS2_SQUASH
bool "Make all files be owned by root"
depends on BR2_TARGET_ROOTFS_JFFS2
-config BR2_TARGET_ROOTFS_JFFS2_DEVFILE
- string "Location of device table file"
- depends on BR2_TARGET_ROOTFS_JFFS2
- default "target/default/device_table.txt"
-
config BR2_TARGET_ROOTFS_JFFS2_OUTPUT
string "Output File"
depends on BR2_TARGET_ROOTFS_JFFS2
default "$(IMAGE).jffs2"
-
+
config BR2_TARGET_ROOTFS_JFFS2_COPYTO
string "also copy the image to..."
depends on BR2_TARGET_ROOTFS_JFFS2
default ""
help
Copies the resulting image to a secondary location.
-
-
+
+
diff --git a/target/jffs2/jffs2root.mk b/target/jffs2/jffs2root.mk
index 0dad3f416..6211ad1f6 100644
--- a/target/jffs2/jffs2root.mk
+++ b/target/jffs2/jffs2root.mk
@@ -7,7 +7,7 @@
JFFS2_OPTS := -e $(strip $(BR2_TARGET_ROOTFS_JFFS2_EBSIZE))
ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2_PAD)),y)
-JFFS2_OPTS += -p
+JFFS2_OPTS += -p
ifneq ($(strip $(BR2_TARGET_ROOTFS_JFFS2_PADSIZE)),0x0)
JFFS2_OPTS += $(strip $(BR2_TARGET_ROOTFS_JFFS2_PADSIZE))
endif
@@ -27,7 +27,7 @@ endif
JFFS2_DEVFILE = $(strip $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_DEVFILE)))
ifneq ($(JFFS2_DEVFILE),)
-JFFS2_OPTS += -D $(JFFS2_DEVFILE)
+JFFS2_OPTS += -D $(TARGET_DEVICE_TABLE)
endif
JFFS2_TARGET := $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_OUTPUT))
@@ -47,6 +47,7 @@ $(JFFS2_TARGET): mtd-host
$(JFFS2_OPTS) \
-d $(BUILD_DIR)/root \
-o $(JFFS2_TARGET)
+ -D $(TARGET_DEVICE_TABLE)
@ls -l $(JFFS2_TARGET)
JFFS2_COPYTO := $(strip $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_COPYTO)))
@@ -54,7 +55,7 @@ JFFS2_COPYTO := $(strip $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_COPYTO)))
jffs2root: $(JFFS2_TARGET)
ifneq ($(JFFS2_COPYTO),)
@cp -f $(JFFS2_TARGET) $(JFFS2_COPYTO)
-endif
+endif
jffs2root-source: mtd-host-source