summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-17 18:21:20 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-17 18:21:20 +0000
commitbb15c2215e6bd1b48a8db0e4d242fee491f774da (patch)
treea8d648677f61d9ce954ba96d5ad78d335b7dc340 /target
parent7d0b7649c95c4e0525911d018fa03150b6639ee0 (diff)
downloadbuildroot-novena-bb15c2215e6bd1b48a8db0e4d242fee491f774da.tar.gz
buildroot-novena-bb15c2215e6bd1b48a8db0e4d242fee491f774da.zip
more changes towards better board support
Diffstat (limited to 'target')
-rw-r--r--target/device/Config.in2
-rw-r--r--target/device/generic/Config.in5
-rw-r--r--target/device/generic/access_point/Config.in6
-rw-r--r--target/device/generic/firewall/Config.in6
-rw-r--r--target/ext2/Config.in5
-rw-r--r--target/ext2/ext2root.mk9
-rw-r--r--target/generic/Makefile.in6
-rw-r--r--target/generic/device_table.txt (renamed from target/device/device_table.txt)0
8 files changed, 7 insertions, 32 deletions
diff --git a/target/device/Config.in b/target/device/Config.in
index 92be4b73d..aff4dfdc9 100644
--- a/target/device/Config.in
+++ b/target/device/Config.in
@@ -1,5 +1,5 @@
menu "Board Support Options"
-source "target/device/generic/Config.in"
+source "target/device/generic/Soekris/Config.in"
endmenu
diff --git a/target/device/generic/Config.in b/target/device/generic/Config.in
deleted file mode 100644
index 29127691f..000000000
--- a/target/device/generic/Config.in
+++ /dev/null
@@ -1,5 +0,0 @@
-comment "Generic Device Support"
-
-source "target/device/generic/access_point/Config.in"
-source "target/device/generic/firewall/Config.in"
-
diff --git a/target/device/generic/access_point/Config.in b/target/device/generic/access_point/Config.in
deleted file mode 100644
index b0166d2f6..000000000
--- a/target/device/generic/access_point/Config.in
+++ /dev/null
@@ -1,6 +0,0 @@
-config BR2_TARGET_GENERIC_ACCESS_POINT
- bool "Generic wireless access point"
- default n
- help
- Board support for a generic wireless access point.
-
diff --git a/target/device/generic/firewall/Config.in b/target/device/generic/firewall/Config.in
deleted file mode 100644
index d20681b15..000000000
--- a/target/device/generic/firewall/Config.in
+++ /dev/null
@@ -1,6 +0,0 @@
-config BR2_TARGET_GENERIC_ACCESS_POINT
- bool "Generic firewall"
- default n
- help
- Board support for a generic firewalling router.
-
diff --git a/target/ext2/Config.in b/target/ext2/Config.in
index e0a3e086b..a40947a03 100644
--- a/target/ext2/Config.in
+++ b/target/ext2/Config.in
@@ -24,11 +24,6 @@ config BR2_TARGET_ROOTFS_EXT2_SQUASH
depends on BR2_TARGET_ROOTFS_EXT2
default y
-config BR2_TARGET_ROOTFS_EXT2_DEVFILE
- string "Location of device table file (blank for none)"
- depends on BR2_TARGET_ROOTFS_EXT2
- default "target/default/device_table.txt"
-
config BR2_TARGET_ROOTFS_EXT2_OUTPUT
string "Output File"
depends on BR2_TARGET_ROOTFS_EXT2
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 61aedddce..c65de3926 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -57,11 +57,6 @@ ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)),0)
EXT2_OPTS += -r $(strip $(BR2_TARGET_ROOTFS_EXT2_RESBLKS))
endif
-EXT2_DEVFILE := $(strip $(subst ",,$(BR2_TARGET_ROOTFS_EXT2_DEVFILE)))
-ifneq ($(EXT2_DEVFILE),)
-EXT2_OPTS += -D $(EXT2_DEVFILE)
-endif
-
EXT2_BASE := $(subst ",,$(BR2_TARGET_ROOTFS_EXT2_OUTPUT))
ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2_GZ)),y)
@@ -77,7 +72,7 @@ $(EXT2_BASE): genext2fs
@rm -rf $(TARGET_DIR)/usr/info
ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
GENEXT2_REALSIZE=`LANG=C du -l -s -c -k $(TARGET_DIR) | grep total | sed -e "s/total//"`; \
- GENEXT2_ADDTOROOTSIZE=`if [ $$GENEXT2_REALSIZE -ge 20000 ] ; then echo 16384; else echo 1200; fi`; \
+ GENEXT2_ADDTOROOTSIZE=`if [ $$GENEXT2_REALSIZE -ge 20000 ] ; then echo 16384; else echo 2400; fi`; \
GENEXT2_SIZE=`expr $$GENEXT2_REALSIZE + $$GENEXT2_ADDTOROOTSIZE`; \
GENEXT2_ADDTOINODESIZE=`find $(TARGET_DIR) | wc -l`; \
GENEXT2_INODES=`expr $$GENEXT2_ADDTOINODESIZE + 400`; \
@@ -86,10 +81,12 @@ ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
-b $$GENEXT2_SIZE \
-i $$GENEXT2_INODES \
-d $(TARGET_DIR) \
+ -D $(TARGET_DEVICE_TABLE) \
$(EXT2_OPTS) $(EXT2_BASE)
else
$(GENEXT2_DIR)/genext2fs \
-d $(TARGET_DIR) \
+ -D $(TARGET_DEVICE_TABLE) \
$(EXT2_OPTS) \
$(EXT2_BASE)
endif
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
index b6596296f..66a369af4 100644
--- a/target/generic/Makefile.in
+++ b/target/generic/Makefile.in
@@ -1,4 +1,4 @@
# Default target skeleton stuff, may be overridden
-TARGET_SKELETON:=target/generic/skel.tar.gz
-TARGET_SKEL_DIR:=target/generic/target_skeleton
-
+TARGET_SKELETON=target/generic/skel.tar.gz
+TARGET_SKEL_DIR=target/generic/target_skeleton
+TARGET_DEVICE_TABLE=target/generic/device_table.txt
diff --git a/target/device/device_table.txt b/target/generic/device_table.txt
index 8b46ca032..8b46ca032 100644
--- a/target/device/device_table.txt
+++ b/target/generic/device_table.txt