summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2008-03-20 22:07:49 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2008-03-20 22:07:49 +0000
commit9169fcccc955f67bd7d18f1b09f3a115288d11e0 (patch)
tree659e9ddf311c32fdf9c8886dc29daccb3cc7765d /target
parent10cacfa02ddb8a80c0d92327afc313f68f0cf753 (diff)
downloadbuildroot-novena-9169fcccc955f67bd7d18f1b09f3a115288d11e0.tar.gz
buildroot-novena-9169fcccc955f67bd7d18f1b09f3a115288d11e0.zip
Do not include Soekris, unless i386 arch
Diffstat (limited to 'target')
-rw-r--r--target/device/Soekris/Config.in8
-rw-r--r--target/device/Soekris/Makefile.in3
2 files changed, 10 insertions, 1 deletions
diff --git a/target/device/Soekris/Config.in b/target/device/Soekris/Config.in
index 6d55fad16..925b3e5dd 100644
--- a/target/device/Soekris/Config.in
+++ b/target/device/Soekris/Config.in
@@ -1,6 +1,11 @@
+menuconfig BR2_TARGET_SOEKRIS
+ bool "Soekris device support"
+ depends BR2_i386
+ default n
+
+if BR2_TARGET_SOEKRIS
config BR2_TARGET_SOEKRIS_NET4521
bool "Soekris net4521"
- depends BR2_i386
default n
select BR2_PACKAGE_LINUX
help
@@ -17,3 +22,4 @@ config BR2_TARGET_SOEKRIS_NET4801
comment "Package support"
depends on BR2_TARGET_SOEKRIS_NET4521 || BR2_TARGET_SOEKRIS_NET4801
+endif
diff --git a/target/device/Soekris/Makefile.in b/target/device/Soekris/Makefile.in
index dad429a28..ce0de96d1 100644
--- a/target/device/Soekris/Makefile.in
+++ b/target/device/Soekris/Makefile.in
@@ -1,4 +1,6 @@
# Override the default uClibc configuration
+ifeq ($(strip $(BR2_TARGET_SOEKRIS)),y)
+
ifeq ($(strip $(BR2_TARGET_SOEKRIS_NET4521)),y)
UCLIBC_CONFIG_FILE:=target/device/Soekris/net4521/uClibc.config
BR2_PACKAGE_BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
@@ -24,3 +26,4 @@ LINUX26_KCONFIG=$(BOARD_PATH)/linux26.config
endif
endif
+endif