summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-09 11:43:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-09 11:43:57 +0000
commit6b539be71b412224fb01737e671432a3a64e0006 (patch)
tree28f7bc60aca3bf3a53a93925d4ea596fa52e300f /target
parent8b69c5e0f62ac682862f2e4b92f6d060e48cb53e (diff)
downloadbuildroot-novena-6b539be71b412224fb01737e671432a3a64e0006.tar.gz
buildroot-novena-6b539be71b412224fb01737e671432a3a64e0006.zip
linux: add knob to force a rebuild of the kernel
Makes development easier. Thanks to Brian Beattie for this handy idea. 1df013316b in Bernhards tree.
Diffstat (limited to 'target')
-rw-r--r--target/linux/Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index bd9f20309..eb2b36ee1 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -233,6 +233,10 @@ linux26-config: host-sed $(LINUX26_DIR)/.configured
linux26-update:
cp -dpf $(LINUX26_DIR)/.config $(LINUX26_KCONFIG)
+# force rebuild
+linux26-force:
+ touch $(LINUX26_DIR)/.configured
+
# This has been renamed so we do _NOT_ by default run this on 'make clean'
linux26clean:
rm -f $(LINUX26_KERNEL) $(LINUX26_DIR)/.configured