summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-23 14:43:40 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-23 14:43:40 +0000
commit170300e045bcdecf5641827eabb4ea63c232ed10 (patch)
tree55ed18100286a8847f28499a59b8ff67da339b01 /target
parentdbdce5dfc5dea27ec71833d2d6a2dd60d2f287ac (diff)
downloadbuildroot-novena-170300e045bcdecf5641827eabb4ea63c232ed10.tar.gz
buildroot-novena-170300e045bcdecf5641827eabb4ea63c232ed10.zip
- revert a part that was introduced with the PROJECT changes.
fixes unability to build a kernel (failed to find rule .patched)
Diffstat (limited to 'target')
-rw-r--r--target/linux/Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index db7be0e69..21b22d814 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -58,7 +58,7 @@ endif
LINUX26_KERNEL=$(BINARIES_DIR)/linux-kernel-$(LINUX26_VERSION)-$(KERNEL_ARCH)
# Version of Linux AFTER patches
-LINUX26_DIR=$(PROJECT_BUILD_DIR)/linux-$(LINUX26_VERSION)
+LINUX26_DIR=$(BUILD_DIR)/linux-$(LINUX26_VERSION)
# for packages that need it
LINUX_VERSION:=$(LINUX_VERSION)
@@ -89,10 +89,10 @@ $(DL_DIR)/$(LINUX26_SOURCE):
$(LINUX26_DIR)/.unpacked: $(DL_DIR)/$(LINUX26_SOURCE)
rm -rf $(LINUX26_DIR)
- $(LINUX26_BZCAT) $(DL_DIR)/$(LINUX26_SOURCE) | tar -C $(PROJECT_BUILD_DIR) $(TAR_OPTIONS) -
+ $(LINUX26_BZCAT) $(DL_DIR)/$(LINUX26_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(DOWNLOAD_LINUX26_VERSION),$(LINUX26_VERSION))
# Rename the dir from the downloaded version to the AFTER patch version
- mv -f $(PROJECT_BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(LINUX26_DIR)
+ mv -f $(BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(LINUX26_DIR)
endif
touch $@