summaryrefslogtreecommitdiffstats
path: root/target/squashfs
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-08-04 06:32:52 +0000
committerEric Andersen <andersen@codepoet.org>2005-08-04 06:32:52 +0000
commitd1345f067e18a2967638eb888c7ff5010d523acf (patch)
tree209a7f9055e89cd63d6f0a7994ae923b12312cb5 /target/squashfs
parent1172dbb8b15c2ccddfa9492850d2f6fbb61e2263 (diff)
downloadbuildroot-novena-d1345f067e18a2967638eb888c7ff5010d523acf.tar.gz
buildroot-novena-d1345f067e18a2967638eb888c7ff5010d523acf.zip
Allow packages to use fakeroot. To accomodate this, convert all
target filesystem creation tools to also use fakeroot.
Diffstat (limited to 'target/squashfs')
-rw-r--r--target/squashfs/squashfsroot.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index abbd61848..d64380d21 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -58,9 +58,6 @@ squashfsroot: squashfs host-fakeroot makedevs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
/sbin/ldconfig -r $(TARGET_DIR)
- # Use fakeroot to munge permissions and do root-like things
- rm -f $(STAGING_DIR)/fakeroot.env
- touch $(STAGING_DIR)/fakeroot.env
# Use fakeroot to pretend all target binaries are owned by root
$(STAGING_DIR)/usr/bin/fakeroot \
-i $(STAGING_DIR)/fakeroot.env \
@@ -71,9 +68,9 @@ squashfsroot: squashfs host-fakeroot makedevs
-i $(STAGING_DIR)/fakeroot.env \
-s $(STAGING_DIR)/fakeroot.env -- \
$(STAGING_DIR)/bin/makedevs \
- -d target/generic/device_table.txt \
+ -d $(TARGET_DEVICE_TABLE) \
$(TARGET_DIR)
- # Use fakeroot to fake out mksquashfs per the previous fakery
+ # Use fakeroot so mksquashfs believes the previous fakery
$(STAGING_DIR)/usr/bin/fakeroot \
-i $(STAGING_DIR)/fakeroot.env \
-s $(STAGING_DIR)/fakeroot.env -- \