summaryrefslogtreecommitdiffstats
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2007-06-12 15:30:32 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2007-06-12 15:30:32 +0000
commit45ac6df37c7b11c00bcec137a4f37a637183dc23 (patch)
tree7e6bdc7d5e4d2323e6d3fb7d495f3d37dfbe9d3d /target/squashfs/squashfsroot.mk
parent6755d78ea6fcfb7f0a8630d94caaba0b2d1c4d88 (diff)
downloadbuildroot-novena-45ac6df37c7b11c00bcec137a4f37a637183dc23.tar.gz
buildroot-novena-45ac6df37c7b11c00bcec137a4f37a637183dc23.zip
Use BR2_ENDIAN for big/little endianness detection
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk20
1 files changed, 3 insertions, 17 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index 515153a0a..c9eb74327 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -35,24 +35,10 @@ squashfs-dirclean:
# Build the squashfs root filesystem image
#
#############################################################
-SQUASHFS_ENDIANNESS=-le
-ifeq ($(strip $(BR2_armeb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_mips)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
SQUASHFS_ENDIANNESS=-be
+else
+SQUASHFS_ENDIANNESS=-le
endif
SQUASHFS_TARGET:=$(IMAGE).squashfs