summaryrefslogtreecommitdiffstats
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-15 16:49:39 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-15 16:49:39 +0000
commit0091f181efdb042e778a357df0ba8ffaddfc9b0c (patch)
tree12579ad566f77af82be219c517dc9b23738058f0 /target/squashfs/squashfsroot.mk
parent2f67d9e2fe7bbec10e67bf7e52999c594c4d6400 (diff)
downloadbuildroot-novena-0091f181efdb042e778a357df0ba8ffaddfc9b0c.tar.gz
buildroot-novena-0091f181efdb042e778a357df0ba8ffaddfc9b0c.zip
- do not use TARGET_DEVICE_TABLE if is is empty
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index ba6450fdb..0ec6f85d2 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -67,9 +67,11 @@ squashfsroot: host-fakeroot makedevs squashfs
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))
echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))
+ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))
+endif
# Use fakeroot so mksquashfs believes the previous fakery
echo "$(SQUASHFS_DIR)/squashfs-tools/mksquashfs " \
"$(TARGET_DIR) $(SQUASHFS_TARGET) " \