summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2008-04-15 17:10:24 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2008-04-15 17:10:24 +0000
commit1262117ee62613e5de0b725eb042c40729e29132 (patch)
treeeec521258ec174a44adc36feda88b8d6d2e05089 /target/linux
parent613fd8488f32331b0b3de4a9e723c60160a1a1d7 (diff)
downloadbuildroot-novena-1262117ee62613e5de0b725eb042c40729e29132.tar.gz
buildroot-novena-1262117ee62613e5de0b725eb042c40729e29132.zip
Reversing bad tftpboot patch resulting in two identical targets
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/Makefile.in.advanced8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/Makefile.in.advanced b/target/linux/Makefile.in.advanced
index c3c70c44c..39a1fb75c 100644
--- a/target/linux/Makefile.in.advanced
+++ b/target/linux/Makefile.in.advanced
@@ -230,7 +230,7 @@ LINUX26_TARGETS+=$(TARGET_DIR)/boot/$(LINUX26_KERNEL_NAME)
endif
ifeq ($(BR2_LINUX_COPYTO_TFTPBOOT),y)
-LINUX26_TARGETS+=$(BR2_LINUX_COPYTO)/$(LINUX26_KERNEL_NAME)
+LINUX26_TARGETS+=/tftpboot/$(LINUX26_KERNEL_NAME)
endif
ifneq ($(strip $(subst ",,$(BR2_LINUX_COPYTO))),)
@@ -437,9 +437,9 @@ $(TARGET_DIR)/boot/busybox.config: $(BUSYBOX_DIR)/.config
mkdir -p $(TARGET_DIR)/boot
cp -dpf .config $(TARGET_DIR)/boot/busybox.config
-$(BR2_LINUX_COPYTO)/$(LINUX26_KERNEL_NAME): $(LINUX26_KERNEL)
- mkdir -p $(BR2_LINUX_COPYTO)
- cp -dpf $(LINUX26_KERNEL) $(BR2_LINUX_COPYTO)/$(LINUX26_KERNEL_NAME)
+/tftpboot/$(LINUX26_KERNEL_NAME): $(LINUX26_KERNEL)
+ mkdir -p /tftpboot
+ cp -dpf $(LINUX26_KERNEL) /tftpboot/$(LINUX26_KERNEL_NAME)
$(LINUX_COPYTO)/$(LINUX26_KERNEL_NAME): $(LINUX26_KERNEL)
mkdir -p $(LINUX_COPYTO)