summaryrefslogtreecommitdiffstats
path: root/target/initramfs
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 14:32:38 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 14:32:38 +0000
commit1afb8226cbaf011f81158b63c2c169ce05842d21 (patch)
treee98b0ceb30d7dc264513db121b16dab45282c9a3 /target/initramfs
parent3cca2a310d5e6a793784c9c5c28076f161713077 (diff)
downloadbuildroot-novena-1afb8226cbaf011f81158b63c2c169ce05842d21.tar.gz
buildroot-novena-1afb8226cbaf011f81158b63c2c169ce05842d21.zip
- start to use BR2_HAVE_MANPAGES and BR2_HAVE_INFOPAGES
- always error out if ldconfig for the target fails (was inconsistent..)
Diffstat (limited to 'target/initramfs')
-rw-r--r--target/initramfs/initramfs.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/initramfs/initramfs.mk b/target/initramfs/initramfs.mk
index dcc0df184..936489c02 100644
--- a/target/initramfs/initramfs.mk
+++ b/target/initramfs/initramfs.mk
@@ -16,9 +16,13 @@ $(INITRAMFS_TARGET) initramfs: host-fakeroot makedevs
rm -f $(TARGET_DIR)/init
ln -s sbin/init $(TARGET_DIR)/init
-find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+ifneq ($(BR2_HAVE_MANPAGES),y)
rm -rf $(TARGET_DIR)/usr/man
+endif
+ifneq ($(BR2_HAVE_INFOPAGES),y)
rm -rf $(TARGET_DIR)/usr/info
- -/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
+endif
+ $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
touch $(PROJECT_BUILD_DIR)/.fakeroot.00000