summaryrefslogtreecommitdiffstats
path: root/target/device/AMD
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-03-10 20:00:25 +0000
committerEric Andersen <andersen@codepoet.org>2005-03-10 20:00:25 +0000
commit0fd5ede9f635c619dcdffc692471a88291a4c81b (patch)
treebac5954c7c032781faffe69eb250acd2829a1837 /target/device/AMD
parent239d88cee2f2ff5ec96756abc83fbfe0c64505d0 (diff)
downloadbuildroot-novena-0fd5ede9f635c619dcdffc692471a88291a4c81b.tar.gz
buildroot-novena-0fd5ede9f635c619dcdffc692471a88291a4c81b.zip
Teach the kernel config to also swing both ways
Diffstat (limited to 'target/device/AMD')
-rw-r--r--target/device/AMD/DBAu1500/linux.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/device/AMD/DBAu1500/linux.mk b/target/device/AMD/DBAu1500/linux.mk
index 6a0c60649..df3453e73 100644
--- a/target/device/AMD/DBAu1500/linux.mk
+++ b/target/device/AMD/DBAu1500/linux.mk
@@ -83,6 +83,9 @@ $(LINUX_DIR)/.configured $(BUILD_DIR)/linux/.configured: $(LINUX_DIR)/.unpacked
$(SED) "s,^ARCH.*,ARCH=$(LINUX_KARCH),g;" $(LINUX_DIR)/Makefile
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" $(LINUX_DIR)/Makefile
-cp $(LINUX_KCONFIG) $(LINUX_DIR)/.config
+ifeq ($(strip $(BR2_mips)),y)
+ $(SED) 's/CONFIG_CPU_LITTLE_ENDIAN=y/# CONFIG_CPU_LITTLE_ENDIAN is not set\n# CONFIG_BINFMT_IRIX is not set' $(LINUX_DIR)/.config
+endif
$(MAKE) PATH=$(TARGET_PATH) -C $(LINUX_DIR) oldconfig include/linux/version.h
touch $(LINUX_DIR)/.configured