summaryrefslogtreecommitdiffstats
path: root/target/cramfs/cramfs.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-05-06 00:17:04 +0000
committerEric Andersen <andersen@codepoet.org>2005-05-06 00:17:04 +0000
commit1515bfd3bbfdd1892d72cdd32ab4394f1ecc9e49 (patch)
treec7007152f3e8afe00f51a9a6bdcc5d7833b72c11 /target/cramfs/cramfs.mk
parent42f7febfb8acfacc5cd613f57b950e1708a6084d (diff)
downloadbuildroot-novena-1515bfd3bbfdd1892d72cdd32ab4394f1ecc9e49.tar.gz
buildroot-novena-1515bfd3bbfdd1892d72cdd32ab4394f1ecc9e49.zip
Teach cramfs to handle byteswapping sanely. I want to specify
big endian or little endian, not whether to unconditionally do byteswapping regardless of build system byte order.
Diffstat (limited to 'target/cramfs/cramfs.mk')
-rw-r--r--target/cramfs/cramfs.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index 5905eb6e5..bc8424000 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -33,23 +33,24 @@ cramfs-dirclean:
# Build the cramfs root filesystem image
#
#############################################################
+CRAMFS_ENDIANNESS=-l
ifeq ($(strip $(BR2_armeb)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_mips)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_powerpc)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_sh3eb)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_sh4eb)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_sparc)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
cramfsroot: cramfs