summaryrefslogtreecommitdiffstats
path: root/target/cpio/cpioroot.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-02 23:10:49 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:33 +0200
commitb605699f1f365c55d094c47737d3f5f7e38c1f61 (patch)
tree74dbf82010675f390f113a772565151286f358db /target/cpio/cpioroot.mk
parent77ab5443080dd994dd9dbe9c9eec302f83525dde (diff)
downloadbuildroot-novena-b605699f1f365c55d094c47737d3f5f7e38c1f61.tar.gz
buildroot-novena-b605699f1f365c55d094c47737d3f5f7e38c1f61.zip
target/: remove the COPYTO mess
There's no need to provide options to copy the filesystem image after the build. Just use 'cp' outside of Buildroot. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/cpio/cpioroot.mk')
-rw-r--r--target/cpio/cpioroot.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index 021847ffd..0984b725f 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -29,8 +29,6 @@ else
CPIO_TARGET := $(CPIO_BASE)
endif
-ROOTFS_CPIO_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_CPIO_COPYTO))
-
cpioroot-init:
rm -f $(TARGET_DIR)/init
ln -s sbin/init $(TARGET_DIR)/init
@@ -52,18 +50,10 @@ endif
chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
$(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
-ifneq ($(ROOTFS_CPIO_COPYTO),)
- $(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
-endif
-endif
ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
$(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT): $(CPIO_ROOTFS_COMPRESSOR_PREREQ) $(CPIO_BASE)
$(CPIO_ROOTFS_COMPRESSOR) $(CPIO_BASE) > $(CPIO_TARGET)
-ifneq ($(ROOTFS_CPIO_COPYTO),)
- $(Q)cp -f $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT) $(ROOTFS_CPIO_COPYTO).$(CPIO_ROOTFS_COMPRESSOR_EXT)
-endif
endif
#############################################################