summaryrefslogtreecommitdiffstats
path: root/sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-09-10 18:58:11 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-09-10 18:58:11 +0000
commitce1dd7b540443b9b487d082ae34989a8b5a2c032 (patch)
treec464c1c490b61cd68e41e099cdbbe89f4afd24d8 /sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch
parentcbd2923af712b3dd5615778294c38c79fccfb31c (diff)
downloadbuildroot-novena-ce1dd7b540443b9b487d082ae34989a8b5a2c032.tar.gz
buildroot-novena-ce1dd7b540443b9b487d082ae34989a8b5a2c032.zip
Integrate gcc 3.4.2 and add patches from both openembedded (6??-*)
and Dan Kegel's crosstools (7??-*). Use makefile vars for toolchain names in ccache.mk and gdb.mk. Fix a g++-related symlink issue with ccache. Change the default to gcc 3.4.2 and binutils 2.15.91.0.2 (now that mips is building). Let the users go forth and test... ;-)
Diffstat (limited to 'sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch')
-rw-r--r--sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch b/sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch
new file mode 100644
index 000000000..a4d87e231
--- /dev/null
+++ b/sources/gcc/3.4.2/810-arm-bigendian-uclibc.patch
@@ -0,0 +1,27 @@
+diff -urN gcc-3.4.1-dist/gcc/config/arm/linux-elf.h gcc-3.4.1/gcc/config/arm/linux-elf.h
+--- gcc-3.4.1-dist/gcc/config/arm/linux-elf.h 2004-08-16 16:08:18.000000000 -0500
++++ gcc-3.4.1/gcc/config/arm/linux-elf.h 2004-08-16 16:06:24.000000000 -0500
+@@ -107,7 +107,7 @@
+ %{rdynamic:-export-dynamic} \
+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0} \
+ -X \
+- %{mbig-endian:-EB}" \
++ %{mbig-endian:-EB} %{mlittle-endian:-EL}" \
+ SUBTARGET_EXTRA_LINK_SPEC
+ #else
+ #define LINK_SPEC "%{h*} %{version:-v} \
+diff -urN gcc-3.4.1-dist/gcc/config.gcc gcc-3.4.1/gcc/config.gcc
+--- gcc-3.4.1-dist/gcc/config.gcc 2004-08-16 16:08:18.000000000 -0500
++++ gcc-3.4.1/gcc/config.gcc 2004-08-16 16:03:25.000000000 -0500
+@@ -666,6 +666,11 @@
+ ;;
+ arm*-*-linux-uclibc*) # ARM GNU/Linux with ELF - uClibc
+ tm_file="dbxelf.h elfos.h linux.h arm/elf.h arm/linux-gas.h arm/linux-elf.h arm/aout.h arm/arm.h"
++ case $target in
++ arm*b-*)
++ tm_defines="TARGET_BIG_ENDIAN_DEFAULT=1 $tm_defines"
++ ;;
++ esac
+ tmake_file="t-slibgcc-elf-ver t-linux-uclibc arm/t-linux"
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
+ gnu_ld=yes