summaryrefslogtreecommitdiffstats
path: root/sources/binutils-001_ld_makefile.patch
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-08-22 12:47:39 +0000
committerEric Andersen <andersen@codepoet.org>2003-08-22 12:47:39 +0000
commit541ecb8d06fe2f1808606fa3ed8f46a285b4922d (patch)
treed5982e7f9a3479d26ca894bef19bb56f8a50e57c /sources/binutils-001_ld_makefile.patch
parent772128bd40162c51a7a7f6fe7074660fdc83a48d (diff)
downloadbuildroot-novena-541ecb8d06fe2f1808606fa3ed8f46a285b4922d.tar.gz
buildroot-novena-541ecb8d06fe2f1808606fa3ed8f46a285b4922d.zip
Make binutils not leak libraries
Diffstat (limited to 'sources/binutils-001_ld_makefile.patch')
-rw-r--r--sources/binutils-001_ld_makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sources/binutils-001_ld_makefile.patch b/sources/binutils-001_ld_makefile.patch
new file mode 100644
index 000000000..c1d2ac1ec
--- /dev/null
+++ b/sources/binutils-001_ld_makefile.patch
@@ -0,0 +1,22 @@
+--- binutils-2.11.90.0.19.orig/ld/Makefile.am
++++ binutils-2.11.90.0.19/ld/Makefile.am
+@@ -19,7 +19,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- binutils-2.11.90.0.19.orig/ld/Makefile.in
++++ binutils-2.11.90.0.19/ld/Makefile.in
+@@ -123,7 +123,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@