summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-23 12:40:43 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-23 12:40:43 +0000
commitdbdce5dfc5dea27ec71833d2d6a2dd60d2f287ac (patch)
tree1c258ed3589c12b8fa406d51e2496a960fd4a985 /package
parenta1144a93415f8ef36b94149cfb63b20f3c10cbe9 (diff)
downloadbuildroot-novena-dbdce5dfc5dea27ec71833d2d6a2dd60d2f287ac.tar.gz
buildroot-novena-dbdce5dfc5dea27ec71833d2d6a2dd60d2f287ac.zip
Cleanup of mplayer package
Diffstat (limited to 'package')
-rw-r--r--package/mplayer/mplayer.mk17
1 files changed, 9 insertions, 8 deletions
diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index 9fe42b350..3634600a6 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -3,10 +3,10 @@
# mplayer
#
#############################################################
-MPLAYER_VER:=1.0rc1
-MPLAYER_SOURCE:=MPlayer-$(MPLAYER_VER).tar.bz2
+MPLAYER_VERSION:=1.0rc1
+MPLAYER_SOURCE:=MPlayer-$(MPLAYER_VERSION).tar.bz2
MPLAYER_SITE:=http://www7.mplayerhq.hu/MPlayer/releases
-MPLAYER_DIR:=$(BUILD_DIR)/MPlayer-$(MPLAYER_VER)
+MPLAYER_DIR:=$(BUILD_DIR)/MPlayer-$(MPLAYER_VERSION)
MPLAYER_CAT:=$(BZCAT)
MPLAYER_BINARY:=mplayer
MPLAYER_TARGET_BINARY:=usr/bin/$(MPLAYER_BINARY)
@@ -22,12 +22,13 @@ $(DL_DIR)/$(MPLAYER_SOURCE):
$(MPLAYER_DIR)/.unpacked: $(DL_DIR)/$(MPLAYER_SOURCE)
$(MPLAYER_CAT) $(DL_DIR)/$(MPLAYER_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(MPLAYER_DIR) package/mplayer/ mplayer-$(MPLAYER_VER)\*.patch\*
- @touch $@
+ toolchain/patch-kernel.sh $(MPLAYER_DIR) package/mplayer/ mplayer-$(MPLAYER_VERSION)\*.patch\*
+ touch $@
$(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
(cd $(MPLAYER_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
+ $(TARGET_CONFIGURE_ARGS) \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
./configure \
@@ -46,16 +47,16 @@ $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
--disable-tv \
--enable-dynamic-plugins \
);
- @touch $@
+ touch $@
$(MPLAYER_DIR)/$(MPLAYER_BINARY): $(MPLAYER_DIR)/.configured
$(MAKE) -C $(MPLAYER_DIR)
- @touch -c $@
+ touch -c $@
$(TARGET_DIR)/$(MPLAYER_TARGET_BINARY): $(MPLAYER_DIR)/$(MPLAYER_BINARY)
$(INSTALL) -m 0755 -D $(MPLAYER_DIR)/$(MPLAYER_BINARY) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
-$(STRIP) --strip-unneeded $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
- @touch -c $@
+ touch -c $@
mplayer: uclibc libmad $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)