summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-10 02:59:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-10 02:59:20 +0000
commitdba033e7a49db26ca45ebbc9c94b4ecbfbc27fab (patch)
treecc56d02b6b6f29f87631efbb8f49dce249077af6 /package
parent57b6a1007db5ecb6b560c2b74804be7d1e360c2a (diff)
downloadbuildroot-novena-dba033e7a49db26ca45ebbc9c94b4ecbfbc27fab.tar.gz
buildroot-novena-dba033e7a49db26ca45ebbc9c94b4ecbfbc27fab.zip
add an option for installing symlinks for supported busybox applets #536
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Config.in14
-rw-r--r--package/busybox/busybox.mk4
2 files changed, 17 insertions, 1 deletions
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index c9b0badf3..5c7bf0184 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -18,6 +18,19 @@ config BR2_PACKAGE_BUSYBOX_SNAPSHOT
For fun, you should say Y.
+config BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS
+ bool "Install symlinks for BusyBox applets"
+ depends BR2_PACKAGE_BUSYBOX
+ default y
+ help
+ If you want to automatically install symlinks for all the
+ supported applets to the busybox binary, then answer Y.
+
+ This may overwrite files from other packages if your
+ busybox includes replacement applets for the package.
+
+ If you wish to just install /bin/busybox, then answer N.
+
config BR2_PACKAGE_BUSYBOX_CONFIG
string "BusyBox configuration file to use?"
depends BR2_PACKAGE_BUSYBOX
@@ -27,4 +40,3 @@ config BR2_PACKAGE_BUSYBOX_CONFIG
file, and will specify their config file location with this option.
Most people will just use the default BusyBox configuration file.
-
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index fe166aa6a..9d15509c7 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -53,8 +53,12 @@ $(BUSYBOX_DIR)/busybox: $(BUSYBOX_DIR)/.configured
EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(BUSYBOX_DIR)
$(TARGET_DIR)/bin/busybox: $(BUSYBOX_DIR)/busybox
+ifeq ($(BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS),y)
$(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" \
EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(BUSYBOX_DIR) install
+else
+ install -D -m 0755 $(BUSYBOX_DIR)/busybox $(TARGET_DIR)/bin/busybox
+endif
# Just in case
-chmod a+x $(TARGET_DIR)/usr/share/udhcpc/default.script