summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-10-28 09:40:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-10-28 09:40:25 +0000
commitbb2d903355505cab2db551472c6fb130dcf9fb83 (patch)
treec5ae7d207d171a281a064be01a67388812cd5e09 /package
parent3d098dd6222e5d6a6dfb17d5ff38ecb377727dc6 (diff)
downloadbuildroot-novena-bb2d903355505cab2db551472c6fb130dcf9fb83.tar.gz
buildroot-novena-bb2d903355505cab2db551472c6fb130dcf9fb83.zip
qtopia4: fix use of pkg-config
When cross compiling, Qt sets PKG_CONFIG in its own configure script to an empty string. That leads to not using pkg-config. To avoid that, use the configure option -force-pkg-config. Also set environment variables for pkg-config defined in TARGET_CONFIGURE_OPTS. Patch by Markus Heidelberg. See http://buildroot.uclibc.org/lists/buildroot/2008-October/011324.html for more details.
Diffstat (limited to 'package')
-rw-r--r--package/qtopia4/qtopia4.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index c959d4001..360b9492e 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -253,10 +253,15 @@ endif
-[ -f $(QTOPIA4_QCONFIG_FILE) ] && cp $(QTOPIA4_QCONFIG_FILE) \
$(QTOPIA4_TARGET_DIR)/$(QTOPIA4_QCONFIG_FILE_LOCATION)
+# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.
+# PKG_CONFIG_SYSROOT is only used to avoid a warning from Qt's configure system
+# when cross compiling, Qt 4.4.3 is wrong here.
(cd $(QTOPIA4_TARGET_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) \
+ $(TARGET_CONFIGURE_OPTS) \
+ PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
./configure \
-verbose \
+ -force-pkg-config \
-embedded $(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM) \
$(QTOPIA4_QCONFIG_COMMAND) \
$(QTOPIA4_CONFIGURE) \