summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-12 22:53:59 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-14 00:38:47 +0100
commit92919160b8a06260463ba3e3a241e433bbe1d947 (patch)
tree88519953ce3789483a3c396fdb8768bb5ce38984 /package
parentaccbd71154b8815678baa12f21f853ed8478f400 (diff)
downloadbuildroot-novena-92919160b8a06260463ba3e3a241e433bbe1d947.tar.gz
buildroot-novena-92919160b8a06260463ba3e3a241e433bbe1d947.zip
hotplug: remove package
The package has been marked deprecated, is no longer developed upstream, so let's get rid of it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/hotplug/Config.in7
-rw-r--r--package/hotplug/diethotplug-0.5.tarbin40960 -> 0 bytes
-rw-r--r--package/hotplug/hotplug.mk45
4 files changed, 0 insertions, 53 deletions
diff --git a/package/Config.in b/package/Config.in
index 0f3eca469..b590867b2 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -170,7 +170,6 @@ source "package/gvfs/Config.in"
source "package/hal/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/hdparm/Config.in"
-source "package/hotplug/Config.in"
endif
source "package/hwdata/Config.in"
source "package/i2c-tools/Config.in"
diff --git a/package/hotplug/Config.in b/package/hotplug/Config.in
deleted file mode 100644
index 48f1d718b..000000000
--- a/package/hotplug/Config.in
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_HOTPLUG
- bool "hotplug"
- depends on BR2_DEPRECATED
- help
- Plug in new devices and use them immediately.
-
- http://linux-hotplug.sourceforge.net/
diff --git a/package/hotplug/diethotplug-0.5.tar b/package/hotplug/diethotplug-0.5.tar
deleted file mode 100644
index 808867070..000000000
--- a/package/hotplug/diethotplug-0.5.tar
+++ /dev/null
Binary files differ
diff --git a/package/hotplug/hotplug.mk b/package/hotplug/hotplug.mk
deleted file mode 100644
index 0b354a85c..000000000
--- a/package/hotplug/hotplug.mk
+++ /dev/null
@@ -1,45 +0,0 @@
-#############################################################
-#
-# hotplug support
-#
-#############################################################
-HOTPLUG_VERSION:=0.5
-HOTPLUG_SOURCE=package/hotplug/diethotplug-$(HOTPLUG_VERSION).tar
-HOTPLUG_SITE=$(BR2_KERNEL_MIRROR)/linux/utils/kernel/hotplug/
-HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-$(HOTPLUG_VERSION)
-HOTPLUG_CAT=cat
-
-$(HOTPLUG_DIR): $(HOTPLUG_SOURCE)
- $(HOTPLUG_CAT) $(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(HOTPLUG_DIR) package/hotplug/ hotplug\*.patch
-
-$(HOTPLUG_DIR)/hotplug: $(HOTPLUG_DIR)
- $(MAKE) CROSS=$(TARGET_CROSS) DEBUG=false KLIBC=false \
- KERNEL_INCLUDE_DIR=$(STAGING_DIR)/usr/include \
- TARGET_DIR=$(TARGET_DIR) -C $(HOTPLUG_DIR)
- $(STRIPCMD) $(HOTPLUG_DIR)/hotplug
- touch -c $(HOTPLUG_DIR)/hotplug
-
-$(TARGET_DIR)/sbin/hotplug: $(HOTPLUG_DIR)/hotplug
- cp $(HOTPLUG_DIR)/hotplug $(TARGET_DIR)/sbin/hotplug
- touch -c $(TARGET_DIR)/sbin/hotplug
-
-hotplug: $(TARGET_DIR)/sbin/hotplug
-
-hotplug-source: $(HOTPLUG_SOURCE)
-
-hotplug-clean:
- rm -f $(TARGET_DIR)/sbin/hotplug
- -$(MAKE) -C $(HOTPLUG_DIR) clean
-
-hotplug-dirclean:
- rm -rf $(HOTPLUG_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_HOTPLUG),y)
-TARGETS+=hotplug
-endif