summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-12 00:23:18 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-12 00:23:18 +0000
commit402920471f9bccf701506ab79d502b939d6effde (patch)
tree56cbb611c58abc969fdba5d1473bd4cca5195c20 /package
parent601b1a1ad18b4fc832a82278c065ca353d5be8bf (diff)
downloadbuildroot-novena-402920471f9bccf701506ab79d502b939d6effde.tar.gz
buildroot-novena-402920471f9bccf701506ab79d502b939d6effde.zip
What is 'wtools'? Give it its proper name 'wireless-tools'
Diffstat (limited to 'package')
-rw-r--r--package/wtools/Config.in4
-rw-r--r--package/wtools/wireless-tools.mk57
-rw-r--r--package/wtools/wtools.mk57
3 files changed, 59 insertions, 59 deletions
diff --git a/package/wtools/Config.in b/package/wtools/Config.in
index 69220cde2..6c20153a1 100644
--- a/package/wtools/Config.in
+++ b/package/wtools/Config.in
@@ -1,5 +1,5 @@
-config BR2_PACKAGE_WTOOLS
- bool "wtools"
+config BR2_PACKAGE_WIRELESS_TOOLS
+ bool "wireless tools"
default n
help
A collection of tools to configure wireless lan cards.
diff --git a/package/wtools/wireless-tools.mk b/package/wtools/wireless-tools.mk
new file mode 100644
index 000000000..4b2355802
--- /dev/null
+++ b/package/wtools/wireless-tools.mk
@@ -0,0 +1,57 @@
+#############################################################
+#
+# wireless-tools - Wireless Tools
+#
+#############################################################
+
+# This Makefile only work with the multicall version of Wireless Tools,
+# which is available in 28-pre3 and later...
+# Jean II
+# v28.pre3 -> earliest possible
+WIRELESS_TOOLS_VER:=28
+WIRELESS_TOOLS_SUBVER:=.pre3
+
+WIRELESS_TOOLS_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
+WIRELESS_TOOLS_SOURCE:=wireless_tools.$(WIRELESS_TOOLS_VER)$(WIRELESS_TOOLS_SUBVER).tar.gz
+WIRELESS_TOOLS_BUILD_DIR=$(BUILD_DIR)/wireless_tools.$(WIRELESS_TOOLS_VER)
+
+$(DL_DIR)/$(WIRELESS_TOOLS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(WIRELESS_TOOLS_SOURCE_URL)/$(WIRELESS_TOOLS_SOURCE)
+
+$(WIRELESS_TOOLS_BUILD_DIR)/.unpacked: $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE)
+ zcat $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ sed -i -e s:'strip':'$(STRIP)':g $(WIRELESS_TOOLS_BUILD_DIR)/Makefile
+ touch $(WIRELESS_TOOLS_BUILD_DIR)/.unpacked
+
+$(WIRELESS_TOOLS_BUILD_DIR)/.configured: $(WIRELESS_TOOLS_BUILD_DIR)/.unpacked
+ touch $(WIRELESS_TOOLS_BUILD_DIR)/.configured
+
+$(WIRELESS_TOOLS_BUILD_DIR)/iwmulticall: $(WIRELESS_TOOLS_BUILD_DIR)/.configured
+ $(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
+ iwmulticall
+
+$(TARGET_DIR)/sbin/iwconfig: $(WIRELESS_TOOLS_BUILD_DIR)/iwmulticall
+ $(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) \
+ PREFIX="$(TARGET_DIR)" \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
+ install-iwmulticall
+
+wireless-tools: $(TARGET_DIR)/sbin/iwconfig
+
+wireless-tools-source: $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE)
+
+wireless-tools-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(WIRELESS_TOOLS_BUILD_DIR) uninstall
+ -$(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) clean
+
+wireless-tools-dirclean:
+ rm -rf $(WIRELESS_TOOLS_BUILD_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_WIRELESS_TOOLS)),y)
+TARGETS+=wireless-tools
+endif
diff --git a/package/wtools/wtools.mk b/package/wtools/wtools.mk
deleted file mode 100644
index 4644526f4..000000000
--- a/package/wtools/wtools.mk
+++ /dev/null
@@ -1,57 +0,0 @@
-#############################################################
-#
-# wtools - Wireless Tools
-#
-#############################################################
-
-# This Makefile only work with the multicall version of Wireless Tools,
-# which is available in 28-pre3 and later...
-# Jean II
-# v28.pre3 -> earliest possible
-WTOOLS_VER:=28
-WTOOLS_SUBVER:=.pre3
-
-WTOOLS_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
-WTOOLS_SOURCE:=wireless_tools.$(WTOOLS_VER)$(WTOOLS_SUBVER).tar.gz
-WTOOLS_BUILD_DIR=$(BUILD_DIR)/wireless_tools.$(WTOOLS_VER)
-
-$(DL_DIR)/$(WTOOLS_SOURCE):
- $(WGET) -P $(DL_DIR) $(WTOOLS_SOURCE_URL)/$(WTOOLS_SOURCE)
-
-$(WTOOLS_BUILD_DIR)/.unpacked: $(DL_DIR)/$(WTOOLS_SOURCE)
- zcat $(DL_DIR)/$(WTOOLS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- sed -i -e s:'strip':'$(STRIP)':g $(WTOOLS_BUILD_DIR)/Makefile
- touch $(WTOOLS_BUILD_DIR)/.unpacked
-
-$(WTOOLS_BUILD_DIR)/.configured: $(WTOOLS_BUILD_DIR)/.unpacked
- touch $(WTOOLS_BUILD_DIR)/.configured
-
-$(WTOOLS_BUILD_DIR)/iwmulticall: $(WTOOLS_BUILD_DIR)/.configured
- $(MAKE) -C $(WTOOLS_BUILD_DIR) \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
- iwmulticall
-
-$(TARGET_DIR)/sbin/iwconfig: $(WTOOLS_BUILD_DIR)/iwmulticall
- $(MAKE) -C $(WTOOLS_BUILD_DIR) \
- PREFIX="$(TARGET_DIR)" \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
- install-iwmulticall
-
-wtools: $(TARGET_DIR)/sbin/iwconfig
-
-wtools-source: $(DL_DIR)/$(WTOOLS_SOURCE)
-
-wtools-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(WTOOLS_BUILD_DIR) uninstall
- -$(MAKE) -C $(WTOOLS_BUILD_DIR) clean
-
-wtools-dirclean:
- rm -rf $(WTOOLS_BUILD_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_WTOOLS)),y)
-TARGETS+=wtools
-endif