summaryrefslogtreecommitdiffstats
path: root/package/xorg/xorg.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-11 10:38:10 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-11 10:38:10 +0000
commite4816a7fdc3048602eff103e933af2fd8ddeaec0 (patch)
tree8e99c8866a20fb58ffd0eccf2e6600bd12924f9f /package/xorg/xorg.mk
parent6113e56a306c3c0e41e1eb64d91742b39b4de4a3 (diff)
downloadbuildroot-novena-e4816a7fdc3048602eff103e933af2fd8ddeaec0.tar.gz
buildroot-novena-e4816a7fdc3048602eff103e933af2fd8ddeaec0.zip
a copy of mcookie will come in handy...
Diffstat (limited to 'package/xorg/xorg.mk')
-rw-r--r--package/xorg/xorg.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/xorg/xorg.mk b/package/xorg/xorg.mk
index 136f26af5..7477a4606 100644
--- a/package/xorg/xorg.mk
+++ b/package/xorg/xorg.mk
@@ -143,8 +143,12 @@ $(XORG_LIBX)/libX11.so.6.2: $(TARGET_XSERVER)
touch -c $(XORG_LIBX)/libX11.so.6.2
+$(TARGET_DIR)/usr/bin/mcookie: package/xorg/mcookie.c
+ $(TARGET_CROSS)gcc -Wall -Os -s package/xorg/mcookie.c -o $(TARGET_DIR)/usr/bin/mcookie
+
xorg: zlib png pkgconfig expat freetype \
- $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2 $(XORG_LIBX)/libX11.so.6.2
+ $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2 \
+ $(XORG_LIBX)/libX11.so.6.2 $(TARGET_DIR)/usr/bin/mcookie
xorg-source: $(DL_DIR)/$(XORG_SOURCE)