summaryrefslogtreecommitdiffstats
path: root/package/xorg/xorg.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 23:25:05 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 23:25:05 +0000
commita461faf1ee09deaf662a45338be1e41a3249a077 (patch)
tree67aadc9b70f25746861974f3fdd3ded53945010a /package/xorg/xorg.mk
parentaf9a0ccb79723bef3c597ea72e417de968164c99 (diff)
downloadbuildroot-novena-a461faf1ee09deaf662a45338be1e41a3249a077.tar.gz
buildroot-novena-a461faf1ee09deaf662a45338be1e41a3249a077.zip
some pkgconfig hacks to make things somewhat work
Diffstat (limited to 'package/xorg/xorg.mk')
-rw-r--r--package/xorg/xorg.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/xorg/xorg.mk b/package/xorg/xorg.mk
index 3f913458a..9f659c9da 100644
--- a/package/xorg/xorg.mk
+++ b/package/xorg/xorg.mk
@@ -105,6 +105,11 @@ $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2: $(XORG_XSERVER)
ln -fs ../../lib $(STAGING_DIR)$(TARGET_LIBX)
( cd $(XORG_DIR); $(MAKE) \
DESTDIR=$(STAGING_DIR) install XCURSORGEN=xcursorgen MKFONTSCALE=mkfontscale )
+ cp package/xorg/x11.pc package/xorg/xext.pc \
+ package/xorg/xproto.pc package/xorg/kbproto.pc \
+ package/xorg/xau.pc package/xorg/xdmcp.pc \
+ package/xorg/xextproto.pc package/xorg/xrandr.pc \
+ package/xorg/xinerama.pc $(STAGING_DIR)/lib/pkgconfig
touch -c $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2
$(TARGET_XSERVER): $(XORG_XSERVER)