summaryrefslogtreecommitdiffstats
path: root/package/xinetd/xinetd-001-ar.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-20 22:16:17 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-20 23:28:27 +0100
commit1f721a2f009393c29c6554f643f15f80a8dc5443 (patch)
treefe6b7b28cf5f2bce9e5aa2e837887ad82fcba3f5 /package/xinetd/xinetd-001-ar.patch
parent77b298c67e4378c53905e504053c38ba52fd0700 (diff)
downloadbuildroot-novena-1f721a2f009393c29c6554f643f15f80a8dc5443.tar.gz
buildroot-novena-1f721a2f009393c29c6554f643f15f80a8dc5443.zip
xinetd: follow the convention for patch location
Following 5538e4766201aa0 ("rework patch model"), the xinetd patches were no longer being applied, because they were stored in package/xinetd/xinetd-2.3.15/*.patch. This lead to xinetd build failures such as: http://autobuild.buildroot.org/results/1a032bca894b76facd9e7f01c3b5d370987d7fc8/build-end.log. This patch fixes this by changing the location and name of the xinetd patches to follow the new conventions. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/xinetd/xinetd-001-ar.patch')
-rw-r--r--package/xinetd/xinetd-001-ar.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/package/xinetd/xinetd-001-ar.patch b/package/xinetd/xinetd-001-ar.patch
new file mode 100644
index 000000000..566f2f75e
--- /dev/null
+++ b/package/xinetd/xinetd-001-ar.patch
@@ -0,0 +1,74 @@
+This patch changes all of the hard-coded invocations of "ar" to $(AR), to
+support a cross-compilation toolchain.
+
+The content of this patch was copied from the OpenWrt project:
+https://dev.openwrt.org/browser/packages/net/xinetd/patches/001-ar.patch
+
+Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
+
+--- a/libs/src/misc/Makefile.in
++++ b/libs/src/misc/Makefile.in
+@@ -62,7 +62,7 @@
+
+
+ $(LIBNAME): $(OBJECTS)
+- ar r $@ $?
++ $(AR) r $@ $?
+ $(RANLIB) $@
+
+ install: $(LIBNAME)
+--- a/libs/src/portable/Makefile.in
++++ b/libs/src/portable/Makefile.in
+@@ -57,7 +57,7 @@
+
+
+ $(LIBNAME): $(OBJECTS)
+- ar r $@ $?
++ $(AR) r $@ $?
+ $(RANLIB) $@
+
+ install: $(LIBNAME)
+--- a/libs/src/pset/Makefile.in
++++ b/libs/src/pset/Makefile.in
+@@ -53,7 +53,7 @@
+ mv $(LIBNAME) $(LIBDIR)/optimized
+
+ $(LIBNAME): $(OBJECTS)
+- ar r $@ $?
++ $(AR) r $@ $?
+ $(RANLIB) $@
+
+ install: $(LIBNAME)
+--- a/libs/src/sio/Makefile.in
++++ b/libs/src/sio/Makefile.in
+@@ -52,7 +52,7 @@
+ $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
+
+ $(LIBNAME): $(OBJECTS)
+- ar r $@ $?
++ $(AR) r $@ $?
+ $(RANLIB) $@
+
+ install: $(LIBNAME)
+--- a/libs/src/str/Makefile.in
++++ b/libs/src/str/Makefile.in
+@@ -63,7 +63,7 @@
+ $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)-O
+
+ $(LIBNAME): $(OBJECTS)
+- ar r $@ $?
++ $(AR) r $@ $?
+ $(RANLIB) $@
+
+ LINT_IGNORE=possible pointer alignment|RCSid unused
+--- a/libs/src/xlog/Makefile.in
++++ b/libs/src/xlog/Makefile.in
+@@ -58,7 +58,7 @@
+ $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
+
+ $(LIBNAME): $(OBJECTS)
+- ar r $@ $?
++ $(AR) r $@ $?
+ $(RANLIB) $@
+
+ install: $(LIBNAME)