summaryrefslogtreecommitdiffstats
path: root/package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-24 08:19:30 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 20:39:07 +0100
commitc415c33959d15b5632708c051acb4fcdacaa90a4 (patch)
tree55e51bc1904f4e724612684ed6a5304a32f9d9da /package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch
parent6ebb930b694e97e5cf85a724957d9c0eb129dea7 (diff)
downloadbuildroot-novena-c415c33959d15b5632708c051acb4fcdacaa90a4.tar.gz
buildroot-novena-c415c33959d15b5632708c051acb4fcdacaa90a4.zip
xcursor-transparent-theme: new package
Based on work originally done by Aleksandar Zivkovic at http://patchwork.ozlabs.org/patch/171109/. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch')
-rw-r--r--package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch b/package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch
new file mode 100644
index 000000000..9cf351f23
--- /dev/null
+++ b/package/x11r7/xcursor-transparent-theme/xcursor-transparent-theme-0001-fix-symlink.patch
@@ -0,0 +1,37 @@
+Do not symlink to a host directory
+
+The installation of xcursor-transparent-theme creates many symbolic
+links to the 'transp' cursor file, but it does so using an absolute
+directory, that happens to point to the installation location, which
+is incorrect when cross-compiling.
+
+Also add the -f option so that the package can be reinstalled even if
+it has already been installed.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/cursors/Makefile.am
+===================================================================
+--- a/cursors/Makefile.am
++++ b/cursors/Makefile.am
+@@ -91,6 +91,6 @@
+ $(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
+ for CURSOR in $(CURSOR_NAMES); do \
+ echo '-- Installing cursor '$$CURSOR; \
+- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
++ ln -sf transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
+ done
+
+Index: b/cursors/Makefile.in
+===================================================================
+--- a/cursors/Makefile.in
++++ b/cursors/Makefile.in
+@@ -177,7 +177,7 @@
+ $(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
+ for CURSOR in $(CURSOR_NAMES); do \
+ echo '-- Installing cursor '$$CURSOR; \
+- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
++ ln -sf transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
+ done
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.