summaryrefslogtreecommitdiffstats
path: root/package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-06-30 12:55:29 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-06-30 12:55:29 +0000
commitd4e56ff4dc8a0528550eb8503956bdcddb2fe516 (patch)
tree2d6f8114da90ab526a5d7595c55ad8559de64366 /package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch
parentaf593cbceefb461c8c089395ff257c05cd290af7 (diff)
downloadbuildroot-novena-d4e56ff4dc8a0528550eb8503956bdcddb2fe516.tar.gz
buildroot-novena-d4e56ff4dc8a0528550eb8503956bdcddb2fe516.zip
packages: fix xorg to compile modular and tiny versions
Based on googlecode r558 by John Voltz.
Diffstat (limited to 'package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch')
-rw-r--r--package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch b/package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch
new file mode 100644
index 000000000..c7bfc9350
--- /dev/null
+++ b/package/x11r7/openchrome/openchrome-0.2.902-cross-compile.patch
@@ -0,0 +1,36 @@
+--- a/configure.ac 2008-04-09 15:42:55.000000000 -0400
++++ b/configure.ac 2008-06-23 09:39:06.000000000 -0400
+@@ -87,12 +87,18 @@ if test x$XSERVER_LIBPCIACCESS = xyes; t
+ fi
+
+ if test "$DRI" != no; then
++ if test "$cross_compiling" = "no" ; then
+ AC_CHECK_FILE([${sdkdir}/dri.h],
+ [have_dri_h="yes"], [have_dri_h="no"])
+ AC_CHECK_FILE([${sdkdir}/sarea.h],
+ [have_sarea_h="yes"], [have_sarea_h="no"])
+ AC_CHECK_FILE([${sdkdir}/dristruct.h],
+ [have_dristruct_h="yes"], [have_dristruct_h="no"])
++ else
++ have_dri_h="yes"
++ have_sarea_h="yes"
++ have_dristruct_h="yes"
++ fi
+ fi
+
+ AC_MSG_CHECKING([whether to include DRI support])
+@@ -133,8 +139,12 @@ AC_MSG_RESULT([$XVMC])
+
+ AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
+
+-AC_CHECK_FILE([${sdkdir}/xf86Module.h],
+- [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
++if test "$cross_compiling" = "no" ; then
++ AC_CHECK_FILE([${sdkdir}/xf86Module.h],
++ [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
++else
++ have_xf86Module_h="yes"
++fi
+
+ # Check the ABI_VIDEODRV_VERSION
+ SAVE_CFLAGS="$CFLAGS"