summaryrefslogtreecommitdiffstats
path: root/package/wtools
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-12 00:25:57 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-12 00:25:57 +0000
commitd2b724eb7c60f734141824e408786ef6ddef3b4c (patch)
tree2eb973cbbcbb5dfcfb0623979c70909a25bdc07d /package/wtools
parent2caf7941bfbb2de9f373baa1b9d6e23f973b993e (diff)
downloadbuildroot-novena-d2b724eb7c60f734141824e408786ef6ddef3b4c.tar.gz
buildroot-novena-d2b724eb7c60f734141824e408786ef6ddef3b4c.zip
kill the older wtools
Diffstat (limited to 'package/wtools')
-rw-r--r--package/wtools/Config.in7
-rw-r--r--package/wtools/wireless-tools.mk57
2 files changed, 0 insertions, 64 deletions
diff --git a/package/wtools/Config.in b/package/wtools/Config.in
deleted file mode 100644
index 6c20153a1..000000000
--- a/package/wtools/Config.in
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_WIRELESS_TOOLS
- bool "wireless tools"
- default n
- help
- A collection of tools to configure wireless lan cards.
-
- http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
diff --git a/package/wtools/wireless-tools.mk b/package/wtools/wireless-tools.mk
deleted file mode 100644
index 4b2355802..000000000
--- a/package/wtools/wireless-tools.mk
+++ /dev/null
@@ -1,57 +0,0 @@
-#############################################################
-#
-# wireless-tools - Wireless Tools
-#
-#############################################################
-
-# This Makefile only work with the multicall version of Wireless Tools,
-# which is available in 28-pre3 and later...
-# Jean II
-# v28.pre3 -> earliest possible
-WIRELESS_TOOLS_VER:=28
-WIRELESS_TOOLS_SUBVER:=.pre3
-
-WIRELESS_TOOLS_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
-WIRELESS_TOOLS_SOURCE:=wireless_tools.$(WIRELESS_TOOLS_VER)$(WIRELESS_TOOLS_SUBVER).tar.gz
-WIRELESS_TOOLS_BUILD_DIR=$(BUILD_DIR)/wireless_tools.$(WIRELESS_TOOLS_VER)
-
-$(DL_DIR)/$(WIRELESS_TOOLS_SOURCE):
- $(WGET) -P $(DL_DIR) $(WIRELESS_TOOLS_SOURCE_URL)/$(WIRELESS_TOOLS_SOURCE)
-
-$(WIRELESS_TOOLS_BUILD_DIR)/.unpacked: $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE)
- zcat $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- sed -i -e s:'strip':'$(STRIP)':g $(WIRELESS_TOOLS_BUILD_DIR)/Makefile
- touch $(WIRELESS_TOOLS_BUILD_DIR)/.unpacked
-
-$(WIRELESS_TOOLS_BUILD_DIR)/.configured: $(WIRELESS_TOOLS_BUILD_DIR)/.unpacked
- touch $(WIRELESS_TOOLS_BUILD_DIR)/.configured
-
-$(WIRELESS_TOOLS_BUILD_DIR)/iwmulticall: $(WIRELESS_TOOLS_BUILD_DIR)/.configured
- $(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
- iwmulticall
-
-$(TARGET_DIR)/sbin/iwconfig: $(WIRELESS_TOOLS_BUILD_DIR)/iwmulticall
- $(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) \
- PREFIX="$(TARGET_DIR)" \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
- install-iwmulticall
-
-wireless-tools: $(TARGET_DIR)/sbin/iwconfig
-
-wireless-tools-source: $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE)
-
-wireless-tools-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(WIRELESS_TOOLS_BUILD_DIR) uninstall
- -$(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) clean
-
-wireless-tools-dirclean:
- rm -rf $(WIRELESS_TOOLS_BUILD_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_WIRELESS_TOOLS)),y)
-TARGETS+=wireless-tools
-endif