summaryrefslogtreecommitdiffstats
path: root/package/wtools
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-11-23 22:01:21 +0000
committerNed Ludd <solar@gentoo.org>2004-11-23 22:01:21 +0000
commit5f3f78f32ba479256038e37b39c5d3ad8ad9c802 (patch)
tree14d30a20ef09d906ec9202c09df4b0b6adc623db /package/wtools
parentdb0dd7a25b05825254bdaba2804d21ba06f100f2 (diff)
downloadbuildroot-novena-5f3f78f32ba479256038e37b39c5d3ad8ad9c802.tar.gz
buildroot-novena-5f3f78f32ba479256038e37b39c5d3ad8ad9c802.zip
wtools-28_pre3 update from the author Jean Tourrilhes. This version is the first to officially support multicall
Diffstat (limited to 'package/wtools')
-rw-r--r--package/wtools/wtools.mk41
1 files changed, 14 insertions, 27 deletions
diff --git a/package/wtools/wtools.mk b/package/wtools/wtools.mk
index 78da5a889..950eafe79 100644
--- a/package/wtools/wtools.mk
+++ b/package/wtools/wtools.mk
@@ -4,16 +4,12 @@
#
#############################################################
-# Pick your version of the Wireless Tools
-# v26 -> obsolete ; won't compile with proper WE because $(KERNEL_SRC) not set
-#WTOOLS_VER:=26
-#WTOOLS_SUBVER:=
-# v27 -> latest stable ; multi WE
-#WTOOLS_VER:=27
-#WTOOLS_SUBVER:=
-# v28.pre1 -> latest
+# This Makefile only work with the multicall version of Wireless Tools,
+# which is available in 28-pre3 and later...
+# Jean II
+# v28.pre3 -> earliest possible
WTOOLS_VER:=28
-WTOOLS_SUBVER:=.pre1
+WTOOLS_SUBVER:=.pre3
WTOOLS_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
WTOOLS_SOURCE:=wireless_tools.$(WTOOLS_VER)$(WTOOLS_SUBVER).tar.gz
@@ -29,24 +25,16 @@ $(WTOOLS_BUILD_DIR)/.unpacked: $(DL_DIR)/$(WTOOLS_SOURCE)
$(WTOOLS_BUILD_DIR)/.configured: $(WTOOLS_BUILD_DIR)/.unpacked
touch $(WTOOLS_BUILD_DIR)/.configured
-$(WTOOLS_BUILD_DIR)/iwconfig: $(WTOOLS_BUILD_DIR)/.configured
+$(WTOOLS_BUILD_DIR)/iwmulticall: $(WTOOLS_BUILD_DIR)/.configured
$(MAKE) -C $(WTOOLS_BUILD_DIR) \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -I." \
- BUILD_SHARED=y # may want to make this an option
-
-$(TARGET_DIR)/sbin/iwconfig: $(WTOOLS_BUILD_DIR)/iwconfig
- # Copy The Wireless Tools
- cp -af $(WTOOLS_BUILD_DIR)/iwconfig $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/iwevent $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/iwgetid $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/iwlist $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/iwpriv $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/iwspy $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/libiw.so.$(WTOOLS_VER) $(TARGET_DIR)/lib
- $(STRIP) $(TARGET_DIR)/sbin/iwconfig $(TARGET_DIR)/sbin/iwevent \
- $(TARGET_DIR)/sbin/iwgetid $(TARGET_DIR)/sbin/iwlist \
- $(TARGET_DIR)/sbin/iwpriv $(TARGET_DIR)/sbin/iwspy \
- $(TARGET_DIR)/lib/libiw.so.$(WTOOLS_VER)
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
+ iwmulticall
+
+$(TARGET_DIR)/sbin/iwconfig: $(WTOOLS_BUILD_DIR)/iwmulticall
+ $(MAKE) -C $(WTOOLS_BUILD_DIR) \
+ PREFIX="$(TARGET_DIR)" \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
+ install-iwmulticall
wtools: $(TARGET_DIR)/sbin/iwconfig
@@ -58,4 +46,3 @@ wtools-clean:
wtools-dirclean:
rm -rf $(WTOOLS_BUILD_DIR)
-