summaryrefslogtreecommitdiffstats
path: root/package/wireless-tools/wireless-tools.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-12 00:25:16 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-12 00:25:16 +0000
commit2caf7941bfbb2de9f373baa1b9d6e23f973b993e (patch)
tree2face0c8d497127648fea37351280409a0dde291 /package/wireless-tools/wireless-tools.mk
parent402920471f9bccf701506ab79d502b939d6effde (diff)
downloadbuildroot-novena-2caf7941bfbb2de9f373baa1b9d6e23f973b993e.tar.gz
buildroot-novena-2caf7941bfbb2de9f373baa1b9d6e23f973b993e.zip
What is 'wtools'? Give it its proper name 'wireless-tools'
Diffstat (limited to 'package/wireless-tools/wireless-tools.mk')
-rw-r--r--package/wireless-tools/wireless-tools.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/package/wireless-tools/wireless-tools.mk b/package/wireless-tools/wireless-tools.mk
new file mode 100644
index 000000000..4b2355802
--- /dev/null
+++ b/package/wireless-tools/wireless-tools.mk
@@ -0,0 +1,57 @@
+#############################################################
+#
+# wireless-tools - Wireless Tools
+#
+#############################################################
+
+# This Makefile only work with the multicall version of Wireless Tools,
+# which is available in 28-pre3 and later...
+# Jean II
+# v28.pre3 -> earliest possible
+WIRELESS_TOOLS_VER:=28
+WIRELESS_TOOLS_SUBVER:=.pre3
+
+WIRELESS_TOOLS_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
+WIRELESS_TOOLS_SOURCE:=wireless_tools.$(WIRELESS_TOOLS_VER)$(WIRELESS_TOOLS_SUBVER).tar.gz
+WIRELESS_TOOLS_BUILD_DIR=$(BUILD_DIR)/wireless_tools.$(WIRELESS_TOOLS_VER)
+
+$(DL_DIR)/$(WIRELESS_TOOLS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(WIRELESS_TOOLS_SOURCE_URL)/$(WIRELESS_TOOLS_SOURCE)
+
+$(WIRELESS_TOOLS_BUILD_DIR)/.unpacked: $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE)
+ zcat $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ sed -i -e s:'strip':'$(STRIP)':g $(WIRELESS_TOOLS_BUILD_DIR)/Makefile
+ touch $(WIRELESS_TOOLS_BUILD_DIR)/.unpacked
+
+$(WIRELESS_TOOLS_BUILD_DIR)/.configured: $(WIRELESS_TOOLS_BUILD_DIR)/.unpacked
+ touch $(WIRELESS_TOOLS_BUILD_DIR)/.configured
+
+$(WIRELESS_TOOLS_BUILD_DIR)/iwmulticall: $(WIRELESS_TOOLS_BUILD_DIR)/.configured
+ $(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
+ iwmulticall
+
+$(TARGET_DIR)/sbin/iwconfig: $(WIRELESS_TOOLS_BUILD_DIR)/iwmulticall
+ $(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) \
+ PREFIX="$(TARGET_DIR)" \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
+ install-iwmulticall
+
+wireless-tools: $(TARGET_DIR)/sbin/iwconfig
+
+wireless-tools-source: $(DL_DIR)/$(WIRELESS_TOOLS_SOURCE)
+
+wireless-tools-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(WIRELESS_TOOLS_BUILD_DIR) uninstall
+ -$(MAKE) -C $(WIRELESS_TOOLS_BUILD_DIR) clean
+
+wireless-tools-dirclean:
+ rm -rf $(WIRELESS_TOOLS_BUILD_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_WIRELESS_TOOLS)),y)
+TARGETS+=wireless-tools
+endif