summaryrefslogtreecommitdiffstats
path: root/package/wayland/wayland.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-04-29 10:26:04 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-30 10:05:55 +0200
commit41c0864646327d6f28d7379b119ae09e58e9acfe (patch)
tree46f7caa866fbbbb6b37d3dd42c77b983878210f0 /package/wayland/wayland.mk
parent67a96673830383028018f254611a9968b9efeffc (diff)
downloadbuildroot-novena-41c0864646327d6f28d7379b119ae09e58e9acfe.tar.gz
buildroot-novena-41c0864646327d6f28d7379b119ae09e58e9acfe.zip
wayland: new package
[Peter: fix scanner comment] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wayland/wayland.mk')
-rw-r--r--package/wayland/wayland.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/wayland/wayland.mk b/package/wayland/wayland.mk
new file mode 100644
index 000000000..a0fadc232
--- /dev/null
+++ b/package/wayland/wayland.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# wayland
+#
+#############################################################
+
+WAYLAND_VERSION = 1.1.0
+WAYLAND_SITE = http://wayland.freedesktop.org/releases/
+WAYLAND_SOURCE = wayland-$(WAYLAND_VERSION).tar.xz
+WAYLAND_LICENSE = MIT
+WAYLAND_LICENSE_FILES = COPYING
+
+WAYLAND_INSTALL_STAGING = YES
+WAYLAND_DEPENDENCIES = libffi host-pkgconf expat host-expat
+
+# wayland needs a wayland-scanner program to generate some of its
+# source code. By default, it builds it with CC, so it doesn't work with
+# cross-compilation. Therefore, we build it manually, and tell wayland
+# that the tool is already available.
+WAYLAND_CONF_OPT = --disable-scanner
+
+define WAYLAND_BUILD_SCANNER
+ (cd $(@D)/src/; \
+ $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
+ -o wayland-scanner scanner.c wayland-util.c -lexpat)
+endef
+
+WAYLAND_POST_CONFIGURE_HOOKS += WAYLAND_BUILD_SCANNER
+
+$(eval $(autotools-package))