summaryrefslogtreecommitdiffstats
path: root/package/python3/python3.mk
diff options
context:
space:
mode:
authorDaniel Nelson <daniel@sigpwr.com>2013-01-27 15:38:56 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-28 22:03:57 +0100
commit6b340425e8af3f6f8e1489eb3550f35ee28b59b9 (patch)
tree5a3eea0a82f5c376c2396c31bf80e552dfa4660d /package/python3/python3.mk
parent08d9ac9fe7972582263254a3c9484fc9826fbfd4 (diff)
downloadbuildroot-novena-6b340425e8af3f6f8e1489eb3550f35ee28b59b9.tar.gz
buildroot-novena-6b340425e8af3f6f8e1489eb3550f35ee28b59b9.zip
python3: Fix pyc-only related runtime exceptions
Python3 changes the pyc lookup strategy, ignoring the __pycache__ directory if the .py file is missing. Change install location to enable use of .pyc without their parent .py See http://www.python.org/dev/peps/pep-3147 [Peter: add patch header] Signed-off-by: Daniel Nelson <daniel@sigpwr.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout at mind.be> (untested) Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python3/python3.mk')
-rw-r--r--package/python3/python3.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index e7c09837e..7551a7b5a 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -70,6 +70,10 @@ else
PYTHON3_CONF_OPT += --with-expat=none
endif
+ifeq ($(BR2_PACKAGE_PYTHON3_PYC_ONLY),y)
+PYTHON3_CONF_OPT += --enable-old-stdlib-cache
+endif
+
ifeq ($(BR2_PACKAGE_PYTHON3_SQLITE),y)
PYTHON3_DEPENDENCIES += sqlite
endif